QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Starting with beta 3.0.0(76)  XML
Forum Index » Beta Version
Author Message
Bruce Giles



Joined: 05-Dec-07 03:47
Messages: 95
Offline

QRecall 3.0.0(76) is my first experience with any of the 3.0 betas. I started by compressing (.zip file) QRecall 2.2.12(1) so that I could recover it if need be. Also made copies of my two existing archive files, and will use the copies with the QRecall 3 betas. Initially, QRecall 3 crashed every time I launched it. After several attempts, all of which failed, I re-installed QRecall 2, and then held down shift-option to do a Quit and Uninstall, which appeared to be successful. Then I launched QRecall again, and this time it launched without crashing -- until I clicked on something in the Quick Start window, and then it crashed. I'm not sure what I clicked, because it happened so fast, but I was aiming for the Open Archive button.

So, I launched QR 3 again and this time tried File > Open. No crash, but it refused to open either of my archives from the QR 2.2.12(1). Log file said "can only decode version 3 and its immediate predicessor". Which I thought was what I had. By the way, note misspelling of "predecessor". Although File > Open didn't work, File > Repair did work. I was able to repair both archives, even though they had not needed repair under QR 2. After repairing both archives, I tried opening them again. This time, one of them, which only had 2 or 3 layers, did open after upgrading itself. I was able to run a backup using QR 3 on that archive. For the second archive, which had 75 layers (been using it for several years), I could open it, but as soon as I tried to do anything with it, it would start to upgrade itself, and after some period of time QRecall 3 would lose its connection with the helper, and the upgrade would never complete. I had noted that the archive had six instances of "Macintosh HD" at the top level, so I thought maybe that was the problem. I tried multiple times to select them and combine them in QR 3, but that always failed as well (lost connection with helper). Eventually, I reinstalled QR 2.2.12.1 long enough to open that archive and combine all the hard drive instances. Then I tried to open the newly-combined archive in QR 3. Once again, it refused to open at all, but it did allow to me Repair it. After that, I could open it in QR 3, but again, as soon as I started to try to do anything with it, it would start the upgrade of the archive format, then a while later 'Lost connection with helper" and "could not send message to helper process".

So, the archive that won't upgrade is my main archive, and I haven't really been able to do anything useful with it in QR 3 yet. When I get more time, I may try a new archive and see how that goes.
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Online

Bruce, that is quite the story of woe! Sorry to hear you're having such a rough time.

First, please send a diagnostic report. I'm particularly interested in your crash logs, because you're getting a lot of crashes for some reason (both versions!) and I think we should start there.


- QRecall Development -
[Email]
Bruce Giles



Joined: 05-Dec-07 03:47
Messages: 95
Offline

James Bucanek wrote:Bruce, that is quite the story of woe! Sorry to hear you're having such a rough time.

That's OK. I pretty much expect that when I'm beta testing. All part of making the software perfect.

First, please send a diagnostic report. I'm particularly interested in your crash logs, because you're getting a lot of crashes for some reason (both versions!) and I think we should start there.

I just sent it. This first report is from my home Mac. I briefly tried it on my office Mac last week, and had some of the same problems. I'll be back in the office again tomorrow, so I'll try it again and send a report from there as well.
Bruce Giles



Joined: 05-Dec-07 03:47
Messages: 95
Offline

Well, this update is a bit delayed, for reasons that have nothing to do with QRecall -- my apologies.

I did get QRecall 3 beta 78 running on my Mac at work. QR 3 wouldn't read my QR 2 archives there either, until I did a repair. After that, they open just fine. The beta mostly works, but I'm still getting a lot of odd errors in the logs. Today, I tried to run a Verify on my main archive, and it found errors and indicated I needed to repair. I've tried twice today to repair, both unsuccessful. The first time was a "lost connection with helper". I couldn't figure out if it actually finished or not, so after a couple of hours, I rebooted. After the reboot, QR 3 indicated there were still problems with the archive, so I tried to repair again. After some period of time, I noticed the numbers in the status dialog were no longer changing, although I did not get a "lost connection" error. Eventually, the entire Mac locked up -- even command-option-escape wasn't allowing me to kill any tasks, so I did a hard reboot by holding down the power button. After a reboot, I did a Disk Utility scan of the boot drive, and it found no problems. I don't know that QRecall was the cause of the lockup, but I rarely have a Mac lock up like that.

I'll send a report from the work Mac.
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Online

Bruce Giles wrote:I did get QRecall 3 beta 78 running on my Mac at work.

Bruce,

I'm assuming you didn't see my email about your earlier problems. I included a link to a pre-release build of QRecall 3.0b79 for you to try. I was particularly interested in how 3.0b79 dealt with your 2.x archives. I expect 3.0b78 to have the same problem(s) as 3.0b76, in that regard.

I'll send the email again (for the details), but you can download the pre-release 3.0b79 and try it. I was hoping on evaluating this change to include, or exclude, it from the next release.

In the mean time, I'll review the diagnostic reports you just sent.

This message was edited 1 time. Last update was at 12-Mar-22 13:44


- QRecall Development -
[Email]
Bruce Giles



Joined: 05-Dec-07 03:47
Messages: 95
Offline

James Bucanek wrote:I'm assuming you didn't see my email about your earlier problems.

No, sorry, I missed it. I was sick for about a week (worst case of food poisoning EVER!) and I'm still not caught up on everything. But I found your re-send, and I'll go get b79 now and let you know what happens. I still have copies of my version 2 archives I can start with.
 
Forum Index » Beta Version
Go to:   
Powered by JForum 2.1.8 © JForum Team