QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Ignore scheduled events while computer is off?  XML
Forum Index » Cookbook and FAQ
Author Message
Bruce Giles



Joined: 05-Dec-07 03:47
Messages: 95
Offline

I recently installed a new SSD in an old iMac, and took the opportunity to wipe out all my old actions, which were no longer doing what I wanted, and start fresh with a new set. But I think I've missed something somewhere...

This iMac doesn't run every day -- more like one or two days a week. The rest of the time it's powered off. I have an archive action for the entire hard drive scheduled for 12:00 PM every day, and an interval action that backs up the home folder every 4 hours. The archive is on an external drive that I usually turn on when I start up the Mac, but not always (depending on how long I intend to run the computer).

The problem is that when I start the Mac after it's been off for a day or more, as soon as I log in, QRecall immediately attempts to run both the both the full backup and the home folder backup. I presume this is because some of the scheduled events occurred during the period that the Mac was off, and now QRecall is trying to catch up for the missed events. This isn't what I want it to do, however. If the event has already passed, I would prefer that QRecall just forget about it and wait for the next scheduled event. I could swear it used to work that way. Did I mis-remember, or did I do something wrong when setting up my scheduled tasks? I thought that maybe "ignore while user is logged out", or "ignore if no archive" would do the trick, but it didn't.

When the backups start running just after login, I usually cancel them from the monitor window. However, if I do that, and then reboot later, the backups attempt to run once again after login, even if another scheduled event hasn't yet occurred. Any ideas?
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Online

Bruce Giles wrote:QRecall immediately attempts to run both the both the full backup and the home folder backup. I presume this is because some of the scheduled events occurred during the period that the Mac was off, and now QRecall is trying to catch up for the missed events.

Correct. If the computer is shutdown (technically, if the QRecall scheduler isn't running), the scheduler will immediately run actions that were scheduled to run while it was shutdown.

If the event has already passed, I would prefer that QRecall just forget about it and wait for the next scheduled event. I could swear it used to work that way. Did I mis-remember, or did I do something wrong when setting up my scheduled tasks?

Bruce, you aren't mis-remembering. As one of QRecall's oldest customers, you probably remember when QRecall didn't run actions while the computer was asleep or shutdown. This generated a lot of complaints and the scheduler was modified to find, and immediately run, actions who's next scheduled time was now in the past.

I thought that maybe "ignore while user is logged out" ... would do the trick, but it didn't.

This depends on whether you're running the scheduler in the background or not. In QRecall > Preferences > Scheduler you'll find an option to "Start and Run actions while logged out". This option controls whether the QRecall scheduler process runs as an agent (only while you're logged in) or as a daemon (installed in the system and run all the time). If this option is off, the scheduler is running as a user agent, which means it start up when you log in and shuts down again when you log out.

If it's running as a user agent, the "ignore while user is logged out" option is worthless; it can't be tested because the action can never be started while you're logged out.

Solution #1: If your system doesn't auto log into your account, you could set the scheduler to run as a daemon and add the "Ignore while user is logged out" option to your capture actions. The computer will start up, the scheduler will start, the actions will try to run, but won't because you're not logged in yet.

I thought that maybe "ignore if no archive" ... would do the trick, but it didn't.

That condition will only skip the action if the volume containing the archive isn't mounted/online at the time that action wants to run.

Solution #2: Add the "ignore if no archive" to your schedule. When you turn on your Mac, don't turn on your external drive. The scheduler will try to run the tardy actions, but see that there's no external drive and skip them. Once you're logged in, turn on your external drive and captures will begin normally.

When the backups start running just after login, I usually cancel them from the monitor window. However, if I do that, and then reboot later, the backups attempt to run once again after login, even if another scheduled event hasn't yet occurred. Any ideas?

That's hard to say. If four hours have passed, or you just logged out and four hours have past, I would expect the capture with the interval schedule to run immediately when you log back in. If the daily action is running immediately after being canceled, then something might be wrong. Start by sending a diagnostic report.

Finally, I'm considering adding an "ignore if asleep or shutdown" condition to actions in QRecall 2.0 so you can simulate the original behavior.

- QRecall Development -
[Email]
Bruce Giles



Joined: 05-Dec-07 03:47
Messages: 95
Offline

James Bucanek wrote:
Bruce Giles wrote:If the event has already passed, I would prefer that QRecall just forget about it and wait for the next scheduled event. I could swear it used to work that way. Did I mis-remember, or did I do something wrong when setting up my scheduled tasks?

Bruce, you aren't mis-remembering. As one of QRecall's oldest customers, you probably remember when QRecall didn't run actions while the computer was asleep or shutdown. This generated a lot of complaints and the scheduler was modified to find, and immediately run, actions who's next scheduled time was now in the past.

Yes, but I thought I remember it behaving that way recently, before I installed the new drive.

Solution #1: If your system doesn't auto log into your account, you could set the scheduler to run as a daemon and add the "Ignore while user is logged out" option to your capture actions. The computer will start up, the scheduler will start, the actions will try to run, but won't because you're not logged in yet.

Ah! I think that was probably what I was doing before. I just checked, and the "Start and run actions while logged out" was turned off. I'm sure it used to be on. I vaguely remember turning if off several weeks ago because I never leave that computer in an "on, but logged out" state, so I was figuring it wasn't necessary. I've just turned it back on again, and I think that will probably solve my problem. The account is indeed set to not automatically log in. I'll make sure to add that action.

Solution #2: Add the "ignore if no archive" to your schedule. When you turn on your Mac, don't turn on your external drive. The scheduler will try to run the tardy actions, but see that there's no external drive and skip them. Once you're logged in, turn on your external drive and captures will begin normally.

I'll add that action too. Some days I'm only on that computer for a few minutes, and if so, I usually don't need to run a backup and usually don't turn on the external drive.

When the backups start running just after login, I usually cancel them from the monitor window. However, if I do that, and then reboot later, the backups attempt to run once again after login, even if another scheduled event hasn't yet occurred. Any ideas?

That's hard to say. If four hours have passed, or you just logged out and four hours have past, I would expect the capture with the interval schedule to run immediately when you log back in. If the daily action is running immediately after being canceled, then something might be wrong. Start by sending a diagnostic report.

It happened today when I installed some software updates immediately after logging in, and then immediately rebooted. I didn't think any scheduled events should have triggered during that time, but I might have been wrong. I'll try to pay more attention, and if it's still happening, I'll send a report.

Finally, I'm considering adding an "ignore if asleep or shutdown" condition to actions in QRecall 2.0 so you can simulate the original behavior.

I almost suggested that, but was thinking maybe you already had and I just wasn't looking in the right place to find it. You can add me as a vote for that action.

So I saw you hint in another message that another beta cycle might be coming up soon. Care to comment any further on that yet?

Thanks, James!
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Online

Bruce Giles wrote:So I saw you hint in another message that another beta cycle might be coming up soon. Care to comment any further on that yet?

QRecall 2.0 has been a study in excitement and frustration. There are a lot of new features, and most are working brilliantly. I've had torture tests running on a dozen separate archives for months now without any major issues.

But there are also several show-stoppers that I've yet to work through, mostly because I'm still mired in under-the-hood changes to modernize the code and bring it up-to-date with Apple's latest APIs and compilers.

It seems that almost every week I think "next week I'll get the beta out," and then I discover something that puts it off another week (or two). I've stopped trying to guess at when it will be ready for its debut, but I still feel like it's close. The point is, it's coming, but not before I'm satisfied that it won't lose anyone's data.

This message was edited 1 time. Last update was at 24-Apr-15 13:43


- QRecall Development -
[Email]
Bruce Giles



Joined: 05-Dec-07 03:47
Messages: 95
Offline

I understand. I'll keep an eye on the forum and wait for the official announcement.
 
Forum Index » Cookbook and FAQ
Go to:   
Powered by JForum 2.1.8 © JForum Team