QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
strange things and oddities testing b13  XML
Forum Index » Beta Version
Author Message
Johannes



Joined: 10-Dec-10 09:54
Messages: 68
Offline

As promissed, here comes my report, what I have encountered so far (I'm on OS 10.10.3):

When updating QR2 did not carry my excluded folders from the actions to the archive. I was under the impression it should ... I should have checked it, my bad. My archive exploded because it stuffed my whole iTunes library in.

I excluded three folders for the archive manually. When I realised that I should have excluded the iTunes library too, it won't stick. I could add it to the list, but the next capture will start again archiving iTunes. I canceled, opened the archive, checked the settings: iTunes is not in the exclude list. Tried it again, it was added to the list. Closed the archive, re-opened it, checked settings: iTunes no longer in the list. Strange. I had to exclude the folder by setting its preferences via command line tool.

While browsing to find out why my archive has started exploding, I noticed that the file sizes in various places do not "match". Folder or Layer sizes where much bigger or smaller than the content. I did not check every item of course but it was strange to find only one GB of data in al Layer that claimed 6 GB. But maybe that is a lack of my understanding of QR's magic.

QR2 suddenly started capturing the system folder. Don't know why. The system has never been part of any QR archive. I checked the action and there was "/" in the list of items to capture. I have no idea how it was added to the list (previous captures of this action behaved well). I deleted the entry. Seems fine for now.

When I browse my archive I see two disks under my user with all the folders like it should be. But the inspector for both disks looks different. One shows the properties like kind, size, owner etc - as it should. The other says: Kind: Placeholder and no further infos beside the list of the layers.

QRecall Capture Preferences is not in the service menu. I searched in the system preferences>keyboard, no luck either. Only the two "old" entries capture to/reveal in Qrecall archive are there. Tried restarting. No luck.

Hope I described everything clearly enough. Otherwise please ask.

Johannes


James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Offline

Johannes wrote:I excluded three folders for the archive manually. When I realised that I should have excluded the iTunes library too, it won't stick. I could add it to the list, but the next capture will start again archiving iTunes. I canceled, opened the archive, checked the settings: iTunes is not in the exclude list. Tried it again, it was added to the list. Closed the archive, re-opened it, checked settings: iTunes no longer in the list. Strange. I had to exclude the folder by setting its preferences via command line tool.

Another bug in the archive's settings dialog. The fix didn't make it into b14, but should be in b15.

While browsing to find out why my archive has started exploding, I noticed that the file sizes in various places do not "match". Folder or Layer sizes where much bigger or smaller than the content. I did not check every item of course but it was strange to find only one GB of data in al Layer that claimed 6 GB. But maybe that is a lack of my understanding of QR's magic.

It's really hard to say. It's sometimes hard to reconcile the size of items in the archive because of complications like invisible items, packages, and other filesystem curiosities.

When I browse my archive I see two disks under my user with all the folders like it should be. But the inspector for both disks looks different. One shows the properties like kind, size, owner etc - as it should. The other says: Kind: Placeholder and no further infos beside the list of the layers.

When you capture an entire hard drive, there will be a volume item in your archive. If you only capture something within the hard drive (like your home folder), all of the enclosing folders leading to that item are stored as "placeholders" in the archive. These items have not been captured—QRecall has no information about them beyond their name. They exists solely to place the captured item at the correction location in the volume's hierarchy.

Given your earlier comment that you suddenly started capturing the whole volume, but then removed that from your captured items, I suspect the "Volume" item is an artifact of capturing the whole volume. You can verify this by looking at what layers it spans. If so, you can delete this item from your archive. The "placeholder" volume should contain your regularly captured sub-items.

QRecall Capture Preferences is not in the service menu. I searched in the system preferences>keyboard, no luck either. Only the two "old" entries capture to/reveal in Qrecall archive are there. Tried restarting. No luck.

In your ~/Library/Services folder you should have a symbolic link named QRecallService.service that points to the QRecallService.service resource in your QRecall application bundle (typically /Applications/QRecall.app/Contents/Resources/QRecallService.service). The log file you sent me says that there was an error removing the old symbolic link, which might have prevented the new one from being installed. Try removing it and running QRecall again.

- QRecall Development -
[Email]
Johannes



Joined: 10-Dec-10 09:54
Messages: 68
Offline

Thanks for your detailed response. After moving the old symbolic link the Services now work as expected. I also found at least one "culprit" for the difference in sizes: I had not shown invisible items (and the hidden ~/Library accounts for quite some data).

I have one issue though:
It seems that the scheduler does not start at system startup. The Monitor says "waiting for scheduler" (or something like that). When I launch Qrecall manually everything starts working fine.
Any hints?

Johannes

This message was edited 1 time. Last update was at 12-Sep-15 04:54

James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Offline

Johannes wrote:Any hints?

Nothing leaps to mind. Send another diagnostic report (since you rebooted) and I'll dig into it.

- QRecall Development -
[Email]
 
Forum Index » Beta Version
Go to:   
Powered by JForum 2.1.8 © JForum Team