QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Disappearing archive  XML
Forum Index » Problems and Bugs
Author Message
Ralph Strauch



Joined: 24-Oct-07 22:17
Messages: 194
Offline

I thought my recent problems had all worked themselves out but I just got a new one. I seemed to have both drives working properly again and then accidentally interrupted a backup to my new drive. I then attempted a repair which appears from the log to have completed, but when I open the archive there's nothing it -- the window is completely blank, while Finder shows the file size as 798gb.

I'm guessing that I should wipe the drive and try it again, but would like your confirmation of that.

Ralph
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Online

Ralph,

You didn't say which archive you were having problems with, but I'm going to assume (from your description) that it was "5th Backup". Here's what I see in the logs:

A whole bunch of successful captures on Feb 28, followed by a merge of a dozen layers.

On March 2, a capture was started at 11:07. At 11:57 a stop (cancel) request was made by the scheduler. (I assume this was a left over stop condition from setting up the incremental capture.) The capture successfully stopped, wrapped up, and committed the items that had been captured up to that point:

Now if this is the "accidentally interrupted" backup you were referring to, then you should note that this was not an unsuccessful capture—it just wasn't allowed to finish. From QRecall's perspective, the capture was successful; all captured files were successfully added to the archive, and the archive was properly closed.

The archive is then opened again and someone deletes the folder "Dont backup":

You then started a verify of the archive, but stopped it before it could finish.

Now here's where things get a little crazy. The archive is opened again and someone deletes the owner "Ralph Strauch"

Since "Ralph Strauch" is the owner, every volume, folder, and file ever captured by that owner (identity key) was deleted from the archive. If "Ralph Strauch" is the only owner that's been captured to this archive, then everything in the archive would have been deleted.

On the other hand, if other owners (identity keys) have captured items to this archive, then those items should still be in the archive.

but when I open the archive there's nothing it -- the window is completely blank

If "Ralph Strauch" was the only owner, then the archive is now, indeed, empty. A blank browser window is exactly what you'd expect to see.

If you expect other owners to be here then first try to use the navigation bar a the bottom of the browser window to navigate to the top-level of the archive, where you will see the other owners.

If the navigation bar is malfunctioning for some reason, you can reset it: (1) close the archive. (2) in the Finder, select the archive and "show package contents" by right+clicking on the archive. (3) inside the archive, discard the view.plist file. (4) reopen the archive in QRecall. That should reset any assumptions the browser window was making about where the view should be in the archive hierarchy.

while Finder shows the file size as 798gb

When you delete items from an archive, using either the delete or merge commands, the records of those items are erased but the space that data occupied remains. Use the compact action to identify, and reclaim, these empty records.

Finally, the archive was repaired several times. I assume this was an attempt to recover the missing items, but I suspect they had already been deleted (see above) and no amount of repairing can recover them as QRecall always securely erases file and directory records.

- QRecall Development -
[Email]
 
Forum Index » Problems and Bugs
Go to:   
Powered by JForum 2.1.8 © JForum Team