QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: Bob Tyson
Forum Index » Profile for Bob Tyson » Messages posted by Bob Tyson
Author Message
James, thank you for that explanation, it all adds up. And for the hint, which of course resolves the nag bit. May I respond to your 'hint' also with this, a slight 'gripe' which is that searching the help on 'status window' produces nothing useful in this regard.

Of course, reading carefully through the 'The Basics' makes all the sense in the world, and I probably did that long long ago when I first set up QR. But this harried user....well....you know the story.

Thanks again.
My puzzlement is because of the opposite to this situation. The monitor or status "eye" in the menu bar (MBP - 10.8.4) is red, but so far as I can tell the archives that are active are ok and incremental backups proceed with no problem.

When I look at the status window, by clicking on the "eye" to open it, there is a long list of items with red "X"s next to them and notes of archive needs repair et cetera. Some show a "repair" button but that does nothing, even with the archive volume and the capture item volume mounted, and QRecall active.

I'm convinced the archives are ok. One reason is that after formatting an archive volume and making a new backup that failed, and produced warning messages, I trashed that faulty QR archive file and re-created a new one in QR, then made an action that completed the new complete archive and subsequently an incremental backup. The whole process proceeded quickly and the status window reports this most recent archive and backup cycle as healthy.

In spite of this the earlier red flag items remain, and the "eye" stays red. I quit QR, restarted the mac, and trashed the library/logs/qr files. The "eye" stays red.

How can I dismiss the "red flag" items and let the "eye" in the menu bar go to white, so it will not cry wolf but only be red if there really IS a problem?
James Bucanek wrote:
Bob Tyson wrote:If I keep backing up to the same archiive I worry that corruption will creep in.

There are lots of good reasons to split (or combine) your backups amongst archives, but trying to protect against corruption isn't one of them.


Of course, and you are quite right. I didn't explain my worry clearly. It would be corruption creeping into the System files over time, and then being backed up where it would be re-introduced during a restore action, that worries me. I'm NOT worried about the backup archives themselves.


James Bucanek wrote:
Bob Tyson wrote: I suggest you develop a backup workflow. I like to start by considering what could go wrong:
- Accidental damage, overwrite, or deletion of my files
- Failure of working system or drive
- Failure of backup storage device
- Failure of secondary backup storage device (if any).


Yes, again. I have tried to cover each of those bases. I like the way I can archive with QRecall, which I have set up to back up the system and my personal set of applications. I've made a "Known Good" initial backup of those elements. Then as a working backup I've backed up the system again, into a second archive so that I can update regularly using QRecall, but preserve that "known good" if disaster should strike.

I have to grant that Time Machine works well for continuous backup and restore of the whole User file set, and I'm using it for that.

My archives are:

Two 1.5 TB drives, each partitioned into two volumes. One volume on each is for User - Time Machine backups; the other on each is for QRecall created backups of the system, applications, and my separate, external data disks.

My "mirror" consists of having Time Machine back everything up to one disk, then the other, to start. Then switch back and forth frequently. Similar habit for QRecall and the other data, or else a simple copy of everything on one disk to the other.

I know there is always a worst (even just "worse"??) case scenario, but then again I could be hit by a bus -- while still asleep in bed?

BT
I am revisiting my backup strategy again. What I would like is a way to separate backup and restore of the OSX system files from the User files.

Following your advice I intend to have QRecall capture two archives: one being System, Applications, and so on; the other the User Home folder with all documents, pictures, music, and so forth.

My reason is that I want to have at least one known-good backup of the System. If I keep backing up to the same archiive I worry that corruption will creep in. On the other hand I want to have a more up to date backup of working files, User materials. I also use Time Machine for finer-grained regular backups.

I prefer not to back up the whole volume because if I do the time to do incremental updates may become long, with QRecall picking up on a zillion new changes through the System, Library, Applications and such.

I do have a bootable disk with a minimal version of the same OSX version, QRecall, and Disk Utility.

Further advice?


OK, I think I've got this thing wired. Success at last. I again performed a RESTORE TO to move the complete volume from one hard drive to another. In this case, back onto the iBook's internal drive.

I checked that 'Ignore Permissions' was NOT checked, and turned QR loose.

There was one hitch. On bootup, the blinking '?'. And now I can't quite recall how I fixed that. I think I rebooted into the previous system, on the external FW disk, then repaired permissions on the newly restored one.

In any case, second time around everything worked, with one oddity.

When I logged in to each user partition - 3 in this case - none of the Home folder contents were visible. Click to open Images, for example, and see nothing. I used Get Info to reset the ownership of each home folder and contents to that user name, logged out and back in, and all was perfect.

I think that situation could be from the permissions fiasco when I originally did the Restore To some time back, without deactivating Ignore Permissions.

Things seem right, now. The only detail I can report is that the icons I had stashed in the folder toolbar have to be re-set, manually. But so far I can't see any other quirks.

Thanks again. All this going on while QR also did captures, merges, and compacts on other archives, of course.
James Bucanek wrote:That, by the way, did not surprise me, although it still seemed to be at odds with your presenting QRecall's Restore To as producing a ready-to-roll clone on the new disk. A detail. It more than a detail, it's a bug. When testing QRecall I have always set the correct permissions option without thinking about it. It honestly never occurred to me that someone would try to restore a system volume without clearing that option. The hazards of testing your own software. .


Hi, back again, mostly to refresh myself once more on the 'Ignore Permissions' check-box. Let's see if I can get it right this time! And thank you for your detailed responses.

I especially liked the 'mia culpa' above about testing one's own software!

If I were to offer any - very modest - suggestion it would be to incorporate some of the meat of what you've offered here into the Help and Manual docs that come with QRecall.

Thanks again, off to the races - er sumpin.
By the way I DON'T want you to assume from this that I'm unhappy with QRecall. I'm a switcheroo from Apple Backup and I'm much more satisfied with QR. No question.
Re: 'Ignore Permissions'

I confess, it is only NOW that I even realized that option existed. I have never SET, i.e. checked the checkbox, to 'Ignore Permissions'.

However now that I look, every one of my external drives has that feature checked. Is that a default that OSX or Disk Utility goes by?

To review, when I started out on this particular swap of system and files between the two disks, the first, was the external FW disk, which I wanted to have become the new, preferred startup volume.

I re-formatted the disk - OSX - Journaled, and zero-ed all data. Then used QRrecall to 'Restore To' the system and all files, that is the existing startup volume, internal disk, on the iBook.

As I noted for you before, there WERE problems with permissions but minimal and things seem ok now. I'd have a hard time remembering just what I needed to tweak but it wasn't much, other than the Adobe licensing issues.

That, by the way, did not surprise me, although it still seemed to be at odds with your presenting QRecall's Restore To as producing a ready-to-roll clone on the new disk. A detail.

The second transfer was to the internal drive and I did not zero all data, so I think what you now say must have been correct, although I do recall seeing the Ignore Permissions check-box. I can't now remember whether I un-checked it.

But I would plead for a more complete instruction set for this procedure.

And now I have another question that arises from the same series of experiences.

I used QRecall to make a backup archive of the newly-christened firewire disk, but when I look to do a new capture or incremental backup it doesn't look the same as for the 'ordinary' kind of archive and backup, that is the options seem to break down to making a new capture of the whole volume or ???

What, for me, would make all of this moot is to have a feature by which one could 'Restore To' for any folder or portion of an ordinary archive, not just a full-volume.

In fact in this case what I would have preferred would have been to have re-installed OSX from scratch on each volume, THEN 'Restored To' from the QRecall Archives. But you can't do that. And the issue of restoring to folders, and whether or not that replaces System-ordained folders such as 'Documents', or creates still ANOTHER set of folders, baffles me.

More detail in the documentation, maybe?
Well, not ALL feedback is so good....

I'm afraid my 'review' of the Capture-Volume-RestoreTO-Volume cycle is negative at this point.

Just to respond to your message above, I zeroed out the volume to which I restored that first go-round, before making the restore. Dunno if that has anything to do with what you describe about ignoring permissions.

I have now 'Restored To' a SECOND volume. This time on startup the gray screen + apple appeared, and the spinning dealie. Nothing more. Restarting in Single User Mode (Apple + S on reboot) and doing and fsck -fy, THEN logout, many many lines of error appeared, then everything stopped and hung.

Went back and re-installed OSX, did the updates to current.

NOW there are permissions problems out of whack all over the place. In the admin partition, had to manually re-set access permission for Desktop, Images, Movies, and a couple of other user folders - for the Admin user.

I don't know what's up. The OS installs on both volumes were good before the swap.

What I - DO - know is that I would be very unlikely to put my faith on a QR backup archive as the way out of a severe disk crash, that is, thinking that 'Oh no prob, we'll be back up in an hour or two'.

It isn't that that is so terrible, but I can say I will not soon let my OSX install DVD stray any farther away from my iBook than my regular (QRecall-ed) backup archives.

It may be that there are subtleties here that I missed. I'm not deeply savvy, though I'll follow instructions. In this case it seems to work out might be less hassle to backup/restore important files on one hand with QRecall, and be prepared to reinstall and initialize a failed system the old-fashioned way, on the other.

Until something slicker proves up.
For James B, hope the feedback may be useful.

I did not attempt the partial restore, but instead worked from a volume capture and later a restore-to. It worked without a hitch, as to doing it. When I tried to boot from the 'restored-to' volume however OSX didn't make it past the gray screen with the apple. No twirly dealie. So I Archive-Installed OSX and that cured that.

The only other thing that seems amiss is that Adobe wanted me to re-install Photoshop, saying some elements were missing. And re-authorize my license.

Only now after doing that, I remember that I did the Startup Volume capture FROM the startup volume, running the OS from that volume. Next time I'd run from a different volume and see if that didn't go any differently.

Thanks again, it's a great piece of work of yours. I just like how it feels day to day, after using it a month. Obviously nothing horrible here at all.
Hmmmm! Actually I think I'm going to do something more straightforward, and suggested by QRecall's basic structure. Maybe this will save you a bit of fussing on my behalf.

What I'm out to do, really, is to exchange the OS and user partitions from my iBook internal drive with the OS and user stuff on an external bootable drive.

FWIW my reason is to have my personal data and confidential stuff on the external drive because I tote the iBook around, use it teaching and so on and worry about security. Schemes such as Apple's FileVault work out to be very clumsy and time-wasting. At any rate this I hope will give me peace of mind, and also more elbow room because the external drive is large.

Thank you, again for your help.
Thank you, sounds like a go. Since I have 3 user partitions on my current startup volume - admin plus two others - and the one I want to 'restore to' is not the admin volue - I bet I'll be back for your voodoo. For now though I'm off to give it a shot.
I want to use QRecall to 'restore' my startup volume to a new external drive, but NOT with the System and associated files. It's time to do a clean install and I want QRecall only to restore User files.

How can I do that? I only find Restore To for a full volume.
 
Forum Index » Profile for Bob Tyson » Messages posted by Bob Tyson
Go to:   
Powered by JForum 2.1.8 © JForum Team