QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: Mike M
Forum Index » Profile for Mike M » Messages posted by Mike M
Author Message
I happened to try that (reinstalling the OS) while I was waiting for your reply and it worked! Thanks for all your help.
In the System Preferences startup disk page, after selecting MacintoshHD and clicking "startup" I get "Running bless to place boot files failed"
I see. I didn't really need to have Mojave to do the restore. In any case, I ran into trouble. After almost finishing, the computer froze. I left it over night and got up to find that the computer had rebooted with the message about "having to restart because of a problem" (I forget the exact wording.) Looking in the log, the last thing it said was "unable to bless Macintosh HD" and something about some versions of the OS can't make a drive bootable.

I sent a diagnostic report to you.

James Bucanek wrote:Mike,

However, if you now believe that your startup volume has been trashed and is unrecoverable, you can restore from QRecall and reinstall macOS. The easiest way to do this is from a second bootable volume. Since you didn't create one ahead of time, create one now—and again, recovery mode and APFS are your friends:

  • Start up in recovery mode

  • Use the Disk Utilities to erase/reformat your startup drive

  • Create a new APFS volume on the drive named Lifeboat (or something)

  • I have a question about this point in the process.

    At this point, the drive "Lifeboat" I want to use to make bootable (with Mojave) is the same drive I installed a bootable copy of Monterey on yesterday. When I go to disk utilities (in recovery mode) it mounts as two APFS volumes. I don't seem to have an option to reformat the entire drive; I can only erase the individual volumes. I'm not sure if I should keep both volumes and reuse them or do something else. I'm not sure if I should even use APFS to make a bootable copy of Mojave.

    Thanks so much for the information. I paid an Apple authorized repair store to install Mojave. I couldn't figure out how to install Mojave and it may even be impossible for me... I tried downloading the installer from the hidden place in the App store but it refused because I was running Monterey. I tried on an older mac and it refused because that Mac couldn't run Mojave. I'll pick up the computer tomorrow and try the QRecall restore again.

    Thanks again! You're a big help.
    Thanks, James. Some updates.

    First let me say that it's not necessarily my goal to run Monterey at the end of this. I'd like to get back to Mojave and try a smaller update to Catalina from there.

    It does seem like Monterey finished installing and that it was the boot sequence where it was hanging. I tried booting in safe mode. The computer was strangely VERY slow but the interesting thing is that it was going through the setup process as if this were a new computer. It was asking for an account name, and all that.

    I probably should have waited at that point but I'm an impatient guy and I had time yesterday. So I read about making bootable disks and ended up running my mac in Recovery mode and installing Monterey on an external drive. I then booted from that external drive, which worked fine. I installed QRecall on it, then restored the Macs system volume.

    At that point the computer was able to boot off its system volume. But it was running Monterey. I naively expected it to be running Mojave.

    Also some stuff is not right. Well, some stuff was right. The three users were there at the startup screen. All of my programs seemed to be installed. But certain of the programs had lost their accessibility features. When I went to the control panel to give them back, when it asked me to enter the administrator password, the user field was blank. I tried typing my account name there "mike" and it didn't work. Maybe I needed to type the longer name that shows on the startup screen? Normally the user field is filled out for me.

    In any case, I'm not too happy right now. It boots, but I really would rather get back to Mojave and I'm not sure I trust everything to be okay if Mojave system files are recalled to a Monterey disk.

    I tried to update for Mojave to Monterey yesterday and after 16 hours of running with no progress on the current progress meter, I'm about ready to give up.

    I'm looking to reinstall the entire Main HD from my latest QRecall backup. Several years ago I set up a backup of the system drive and my understanding is that I can restore it.

    However, looking at the directions I see many ways to do this and I'm not clear what would be applicable to my situation. I don't think my System drive is currently bootable. I don't think I made a bootable drive several years ago when I set this up. I'm comfortable with command lines. What would you recommend at this point?

    I followed your earlier advice and increased the detail level of the log. The log entry about the recall problem came back and it was about an inability to create a file and a directory. Both of them had "spotlight" in the name so I'm going to assume they were not important data. I've resolved this to my satisfaction.

    I didn't know before that you can increase log detail. That's really good to know.
    I found the section of the log at the point the restored finished. Maybe you can explain this.

    But I'm thinking that if the recall was incomplete, then I'm missing data, and the next time QRecall captures that disk it will mark those files as deleted. In fact it already did do a capture of that disk. If I do a verify now, of course it will succeed. What I'd really like to do is verify it against the archive at the time of recall.

    Actually I was recalling an external drive that has no programs on it and is not the boot drive, just data.

    Strangely there was a log entry while the recall was running, but it disappeared. I thought about doing a verify before QRecall captured the external drive again, but it already did capture it again and might think the missing files are not there on purpose. Can you throw away a layer in the archive, then do a verify? Does verify tell you what files are missing/corrupted or does it just fail?

    I just did a recall of an external drive that I had accidentally wiped. The final notification was something like "recall incomplete."

    While the recall was in progress, there was a log entry. It showed one file that was unable to be restored, but it was trivial, like a spotlight file or some other hidden file.

    But now that the recall is done, I wanted to check the log again and there's no log entry! My goal is to find out what files were not successfully recalled and just make sure there were no significant issues.
    You were right! There are two copies of many of the folders. How do I resolve this?

    I'm backing up folders on a drive I call B1. So there's B1/Folder1, B1/Folder2 etc.

    When I look at the archive, I see two pictures of a drive labeled B1. And inside each are Folder1 and Folder2, etc.. However, there are some differences in the folders in each one. When I use the timeline to narrow the view to recent captures, only one of them shows. How can I be sure it has all the files .. and then a worse problem, how do I know which picture of "B1" is which when I go to delete the one I don't want?
    I have a drive with about 950GB of large audio and video files. I back that up with QRecall, but it's on a pretty infrequent schedule and the files don't change that much. Right now the QRecall archive is 1.4 TB. When I do a compact, it says "not enough free space to do a compact" or something similar. But it's 40% bigger than the sum of the files. There may be a few 10's of GB in old layers but I can't really imagine how it gets to 1.4 TB. WAIT.. is it the redundancy? Does this sound normal?
    thanks. I'm running on a compact on the other two archives. We'll see if it finishes faster.
    Forum Index » Profile for Mike M » Messages posted by Mike M
    Go to:   
    Powered by JForum 2.1.8 © JForum Team