QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: Ralph Strauch
Forum Index » Profile for Ralph Strauch » Messages posted by Ralph Strauch
Author Message
One of my backup volumes has been randomly disconnecting during a backup and again during attempts to repair it. The drive is three and a half years old and may have just reached the end of it's life, but I'm sending a report in case you can glean anything from it.


Thanks for this information. The iCloud files I want to back up are contained in my ~/Library/Mobile Documents folder, and appear in the archive with "Show Invisible Items" turned on. This assuages my concern that they weren't being backed up. Interestingly, though, when I open that Mobile Documents file in Finder, the title bar reads ""iCloud Drive" rather than "Mobile documents." I don't understand what determines whether the computer keeps a locally cached copies or a placeholders, but this is enough for me for now, at least.

On 4/7 I reported that Qrecall would not back up files stored on iCloud drive, and on 4/9 you replied that that might be because " the iCloud folder is actually a mountpoint . . ." I've now got some new information to add. I'm describing out previous exchange rather than replying to it, because it somehow became part of the first thread in the topic which is locked and not reply-able to.

I happened to glance at the Qrecall Activity Monitor today as it was processing a folder from the iCloud drive, and though "hey, maybe this is working now." After the backup finished, though, I looked in the archive and the iCloud files weren't there. The log does show

Action 2018-05-04 13:56:02 Capturing 3 items
Action 2018-05-04 08:56:20 Capture MBP-HD
Action 2018-05-04 08:56:20 Capture Finances Strauch.scsf
Action 2018-05-04 08:56:20 Capture Meditation stuff

The last two items, Finances Strauch.scsf and Meditation stuff are a file and folder stored on iCloud. I'm sending a report. I can live with this and don't need an immediate fix, but I'm passing it along FYI.

I'm using the new beta and it seems to be working fine. I've found a new problem, though. I'd like to back up some files that are stored on iCloud drive to be accessible from other computers, but Qrecall doesn't seem willing to back them up from iCloud. As a starter, I've defined an action to back up one file and one folder from iCloud drive. The action runs, and shows some activity, but nothing is backed up and no layer is created.
What seems to be happening is that both of my USB drives are spontaneously unmounting and remounting, and when my FW drives is mounted along with a USB drive, it unmounts and mounts at the same time. If the FW drive is mounted by itself, though, it's solid and doesn't unmount. Thanks for pointing out the logs to me; I can use that to troubleshoot the cables and power supplies.

I've been having a problem, though, trying to open ~Library/Logs/Qrecall/Qrecall.log in Console, because when I click on it, Console freezes up. The older logs open fine; just the current log freezes. When I looked at that log in Finder, I found the problem. it's 14.32GB. Yes, GB, and that's just since the first of the year. No wonder Console was choking on it. When I open the file with Quicklook, it looks like most of it was written yesterday. Can I just pull that file out of the Logs folder and start a new one? DDo you have any sense of what's going on here, and do you want this monster for anything?

Thanks for the reply, James. I guess I've been thinking qrecall had problems at times when it didn't, and knowing that I can ignore some of the "communications problems" gives me more confidence. I just ran an MBP backup on fresh drive and it went without a hitch.

All is not yet well, though. I ran another backup of the same system on one of my older archives, and it stopped running after about 2 hours and the computer gave me a "Drive not Ejected Properly" error message. When I looked at the Finder, however, the drive was still plugged in and connected. The qrecall activity window stopped at the point where this happened, showing a partially completed backup. So somehow qrecall lost contact with the drive but the computer didn't. The Qrecall log stops with "Capture Issues." Activity Monitor show Qrecall, Monitor, Scheduler, and two versions of Helper still running.

I just walked into the other room where my iMac was running a repair on another older archive to find the same situation. Qrecall said that the drive was not ejected properly, but Finder still finds it there. The last entry in the Qrecall log is Repair, twice. Activity monitor shows Qrecall and two versions each of Monitor and Scheduler, no Helper.

Lastly, as I'm writing this, the MBP just popped up another "Drive not Ejected Properly" message, while the drive is still sitting there, connected but not being accessed afaik.

Both of these drives are 3-4 years old, and perhaps they've outlived their usefulness. In general, though, they seem to work. Can you tell anything more about what's happening from my logs?


I'm still unable to back up my MBP running High Sierra. I thought I had posted a recent summary yesterday, but don't see it here so perhaps I forgot to hit send. I did submit a report yesterday.

Since my problems looked like they might have been drive or network issues, I ran a new backup of my MBP on a clean drive (7th bu.quanta in the log). The first time I ran it (2017-12-31 21:58:14 it failed, but I was able to repair it. I reran it and seemed to go to completion(2018-01-02 16:37:01) but the log showed communications problems, so I Verified the archive (2018-01-03 07:36:11) and the verify log listed communications problems. The drive I used for this backup was a firewire 800 drive connected through a TB to FW adapter, while my regular backup drives are USB3.

One issue I'm having consistently through this is that Qrecall tends to hang up and ask for a Force Quit. It will sometimes unhang itself after several minutes if I leave it alone.
I've uninstalled and reinstalled Qrecall, and as you predicted, that didn't make any difference. I have a better handle now on the problem, though, and I think the underlying cause is the High Sierra update.

I backup an iMac and a MBP to the same archive, and swap between two archives, one of which is stored offsite. The active archive is routinely mounted on the iMac, but gets mounted briefly on the MBP for maintenance when I make the swap. The difficulties I'm having all seem to come from my MBP, which I upgraded to 10.13.2 a couple of weeks ago. (The imac is still on 10.12, and will stay that way for a while.)

The freezing that I described when opening an archive turned out to be only a temporary hang. I just wasn't waiting long enough for it to resolve. Backups run on the MBP are still causing errors that require repair of the archive, and I've had to repair both archives.

Once Qrecall opens an archive, the only way to unmount that drive (without just pulling the plug) is to shut down the computer. Eject won't work, it just produces a notice that something else is using the file. This persists even when Qrecall and all other running apps have been quit, and even when I've logged out of my account and try to eject the drive from a different account. The only way to disconnect the drive seems to be Shutdown. The problem does not occur with files opened by other apps.

I'm sending a report, but I don't need you to spend any more time on this right now. Qrecall is working fine on the iMac, so I can keep it backed up from there. I'll stop using Qrecall for the MBP until macOS 10.13.3 comes out, and see if that fixes the problem.

Thanks again for the great support you provide.

I've been having intermittent problems with Qrecall on my MacBook Pro for a couple of weeks. A backup might run all the way through, then report a problem closing the archive when it was done. Sometime immediately rerunning the backup immediately seemed to fix the problem. Yesterday and today, though, Qrecall is consistently freezing as soon as I try to open an archive, requiring a force-quit to get the computer back. This happens with three different archives on two different hard drives. Repairing the archive appeared to fix a number of problem in the archive but not solve the freezing issue.

My next step, I think, should be to reinstall Qrecall from scratch, and I'm wondering what Qrecall files I should trash I should discard as part of my cleaning process before I do that.

I thought my recent problems had all worked themselves out but I just got a new one. I seemed to have both drives working properly again and then accidentally interrupted a backup to my new drive. I then attempted a repair which appears from the log to have completed, but when I open the archive there's nothing it -- the window is completely blank, while Finder shows the file size as 798gb.

I'm guessing that I should wipe the drive and try it again, but would like your confirmation of that.

The incremental capture was what I needed. I set that up yesterday afternoon on the MBP with the new backup drive, which had been unmounting partway through the backup each time. The first three incremental captures worked fine, then there were several failures with Qrecall reporting problems communicating with helper. Then around 10pm the incremental captures started working again and ran through the night without problems. I'm sending a report from the MBP.

My other backup drive is currently attached to the iMac, and the problems I was having with that earlier this week seem to have disappeared. My next step will be to move this drive over to the iMac and back that up, then go back to my usual routine of backing up the MBP over the network and keeping one of the backup drives off-site.
I've been having problems for a couple of weeks with my backup drives spontaneously dismounting part way through a backup. Sometimes I can restart the backup and it will complete, sometimes I can't. This may be an OS or connection problem rather than a Qrecall problem, but I'm mentioning it here in case you have any ideas or can tell anything about it from my report.

This has been happening with two different computers and two different backup drives, connected both directly and over wifi. In case both those drives were bad I bought a new drive and it has similar problems. When I tried to backup my MBP into a fresh archive on the new drive it ran for a while and the disk dismounted after backing up 87gb (of about 400 on the drive). I started it again and went to bed, hoping to add to the archive, and it stopped at 89gb. When I got up in the morning the archive showed up as 38gb in the finder, but when I tried to open it in qrecall that all disappeared and archive was empty. I ran it again today, and it quit with an archive that shows in the Finder as 89gb, but internally shows 1 layer containing 75kb incomplete.

As I'm writing this I think I remember you saying something to another user about a problem being caused by qrecall failing after using up all the empty space on a drive with temporary files, and I'm wondering if something like that could be happening here? If so, how can I work around it?

Any thoughts you have on this would be welcome.

My iMac has started to refuse to do captures, giving me a "Capture requires an identity key" error message. The Qrecall Preferences, though, still show my Key Status as "Valid Permanent Key." The key on this machine was installed in 2011, when the computer was new, and I haven't had amy problem with it till this week.

I've tried re-entering my key but when I do I get a warning that I'm entering a new key and that will create a new owner for all subsequent captures. This archive contains backup volumes for both this my MBL (owner "ralph") and this iMac (previous owner "merna" but currently showing up as "Ralph Strauch," and I don't know where that's coming from. Should I just go ahead and put my key back in, them merge the old iMac volume with whatever new one gets created after I run a backup?

I have an archive that I can't open, that keeps telling me the index needs repair. When I try to repair the archive, the repair appears to run normally, then fails to complete and close the file when it's done. This happens with the drive mounted on two different computers. Both Disk Utility and TechTool Pro give the drive a clean bill of health. Can you tell from the Report whether the problem is with the archive or with the drive, and if the former, how I can repair it?
Here they are

Forum Index » Profile for Ralph Strauch » Messages posted by Ralph Strauch
Go to:   
Powered by JForum 2.1.8 © JForum Team