QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
QRecall and ext3 - Will it work?  XML
Forum Index » Cookbook and FAQ
Author Message
ubrgeek



Joined: 01-Aug-08 06:46
Messages: 19
Offline

James - Looks like the backup is working well on the MBP. Trying to do a backup with the wife's PB G4 and it keeps failing, telling me the other machine most likely disconnected or a disk failure. I don't believe the first is happening and I checked and the disk is fine. Can I send along the log file and see if you have any ideas?
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1473
Offline

ubrgeek wrote:Can I send along the log file and see if you have any ideas?
Always. Just choose Help > Send Report... and I'll take a look at it.

- QRecall Development -
[Email]
ubrgeek



Joined: 01-Aug-08 06:46
Messages: 19
Offline

OK, thx. Just sent it.
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1473
Offline

ubrgeek,

I just looked at the log file you sent and it's a bit of a mystery. The capture is fails to write to the archive with OS error -51. This is an "invalid reference number" error.

When an application opens a file, it gets a "reference number" which it then uses to read and write to that file. When the file is closed, that reference number becomes invalid.

I can't think of any good reason why this might be happening. Some file/operating systems have limits about how many files can be open at once. I'm wondering if the SMB drivers on the PowerMac is losing track of what files it has open? Or maybe the volume is getting disconnected and reconnected (this happens all the time on my WiFi), and after reconnecting it has forgotten what files it had open? (I'm mostly thinking out loud here.) I'll post this question on one of the technical forums and see if anyone has any good ideas.

This message was edited 1 time. Last update was at 07-Sep-08 18:10


- QRecall Development -
[Email]
ubrgeek



Joined: 01-Aug-08 06:46
Messages: 19
Offline

Thanks James. Like I said, the connection is strong and maintained, so I'm probably 99% certain that's not the problem.
Ralph Strauch



Joined: 24-Oct-07 22:17
Messages: 194
Offline

You might try closing other apps when you do a backup, to minimize the number of open files the system has to deal with. That should at least confirm or eliminate that as the source of the problem.

Ralph

This message was edited 1 time. Last update was at 08-Sep-08 11:08

ubrgeek



Joined: 01-Aug-08 06:46
Messages: 19
Offline

Excellent point. I _thought_ I had, but will reconfirm tonight when I try again.
ubrgeek



Joined: 01-Aug-08 06:46
Messages: 19
Offline

I quit all apps and left it running overnight. It seemed to be working better (looks like it a decent amount in) but when I checked it this a.m. I had the same error msg. Confirmed the network connection was fine and the remote disk was good.

I'm going to see if I have a spare external drive I can connect to the laptop and see if that works.

This message was edited 1 time. Last update was at 09-Sep-08 07:28

ubrgeek



Joined: 01-Aug-08 06:46
Messages: 19
Offline

By chance, any update?
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1473
Offline

I was hoping you had an update.

I can find nothing in the code to explain what's happening. So for now I'm going with the assumption that the problem is coincident with using this particular storage device.

The first diagnostic is to try it with a different device. You were going to perform the same capture on the same machine using an external drive. Have you had a chance to do that, and were the results different?

- QRecall Development -
[Email]
ubrgeek



Joined: 01-Aug-08 06:46
Messages: 19
Offline

I forgot about that. Haven't yet. Will try tonight. Issue was fixed with the different build you gave me for the same storage device. Only difference now is the machine I want to back up isn't an Intel device - the "fixed" one is.
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1473
Offline

The previous fix for the SMB volumes wasn't Intel specific and the problem being reported by the G4 is completely different than the problem encountered by your Intel system. I suspect that the old version of QRecall that had problems with the SMB volume on the Intel would have had the same problems on the G4. If it didn't have that same problem, then that would be interesting.

I also wouldn't be surprised at all if there were subtle platform-specific differences between the Samba drivers on the G4 vs. those your Intel system.

This message was edited 1 time. Last update was at 27-Sep-08 10:05


- QRecall Development -
[Email]
 
Forum Index » Cookbook and FAQ
Go to:   
Powered by JForum 2.1.8 © JForum Team