QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Unable to repair archive...  XML
Forum Index » Beta Version
Author Message
Steve Mayer



Joined: 25-Oct-08 10:53
Messages: 70
Offline

Using the latest beta(1.2.0(80)rc), I've gotten into a situation where I'm unable to capture anything to my archive any longer as I seem to be stuck in a cycle of Index is bad, repair index, repair, error Index is bad, repair incomplete actions.

The one thing that I can see in the log that seems to be a recurring theme is :

QRecall 2012-06-08 12:32:34 archive file out of sequence
QRecall 2012-06-08 12:32:34 Expected: 972
QRecall 2012-06-08 12:32:34 Sequence: 969

Any idea how to fix this or what might be up?

Thanks,

Steve
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Offline

Steve Mayer wrote:Using the latest beta(1.2.0(80)rc), I've gotten into a situation where I'm unable to capture anything to my archive any longer as I seem to be stuck in a cycle of Index is bad, repair index, repair, error Index is bad, repair incomplete actions.

Steve,

Your archive has a broken package index file, but I don't know why repair isn't fixing it.

First, please open up a Terminal window and issue the following command, copy the output and send me the results.


Then you might try opening up the SpawnSmayerHome.quanta package, trashing all of the .index files, and then attempt to repair the archive.

In the mean time, I'll look at your log file records in detail.

- QRecall Development -
[Email]
Steve Mayer



Joined: 25-Oct-08 10:53
Messages: 70
Offline

Here's the output:

spawn :: ~ ยป ls -l /Volumes/SpawnBackup/SpawnSmayerHome.quanta
total 125056720
-rw-r--r-- 1 smayer staff 48 Jun 8 15:42 displayname.index
-rw-r--r-- 1 smayer staff 48 Jun 8 15:42 filename.index
-rw-r--r-- 1 smayer staff 56 Jun 8 15:42 fill.index
-rw-r--r-- 1 smayer staff 201326648 Jun 8 15:42 hash.index
-rw-r--r-- 1 smayer staff 40 Jun 8 15:42 layer.index
-rw-r--r-- 1 smayer staff 16777220 Jun 8 16:11 negative.index
-rw-r--r-- 1 smayer staff 862 Jun 2 04:09 outline.index
-rw-r--r-- 1 smayer staff 16551984 Jun 9 04:03 package.index
-rw-r--r-- 1 smayer staff 63794332528 Jun 9 04:03 repository.data
-rw-r--r-- 1 smayer staff 691 May 18 04:08 settings.plist
-rw-r--r-- 1 smayer staff 1006 Jun 9 04:03 status.plist
-rw-r--r-- 1 smayer staff 4586 Jun 8 15:42 view.plist

I'll try deleting the .index files and repairing again. I'll let you know.

Thanks!
Steve Mayer



Joined: 25-Oct-08 10:53
Messages: 70
Offline

So, after deleting the .index files, I tried reindexing the archive. I got an error that while the index had completed, the auto-repair had failed. I tried a capture and that failed after about 2%.

Thanks.
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Offline

Steve Mayer wrote:So, after deleting the .index files, I tried reindexing the archive. I got an error that while the index had completed, the auto-repair had failed. I tried a capture and that failed after about 2%.

Please send another diagnostic report. I really want to look at the results of that reindex and capture.

Thanks.

- QRecall Development -
[Email]
Steve Mayer



Joined: 25-Oct-08 10:53
Messages: 70
Offline

Sent
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Offline

Steve,

You win this month's obscure bug contest.

You are encountering a problem recovering a file with an unusually large extended attribute. The repair logic is getting tripped up by errors in processing the list of data blocks associated with that extended attribute.

I think I've addressed the problem and have built 1.2.0(82) alpha for you to try. Install 1.2.0a82 and repair the archive again, and then try another capture.

The problem with the extended attribute data appears to be the result of an earlier data corruption. So if you haven't done so already, I'd suggest repairing the volume that contains this archive before you proceed.

Please send another diagnostic report afterwards.

- QRecall Development -
[Email]
Steve Mayer



Joined: 25-Oct-08 10:53
Messages: 70
Offline

Updated to 1.2.0(82) and ran a repair, capture, merge, compact and index rebuild with no errors. There was one mention of a corrupted file, but it did not stop the procedures. Great job James! Diagnostics report should be uploaded shortly.
 
Forum Index » Beta Version
Go to:   
Powered by JForum 2.1.8 © JForum Team