QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Virtual Machines folder not captured  XML
Forum Index » Beta Version
Author Message
Bruce Giles



Joined: 05-Dec-07 03:47
Messages: 95
Offline

I've moved this to a new thread:

Bruce Giles wrote:
James Bucanek wrote:Tip: I'd also suggest setting the "Deep Scan" option for the VM folder capture action, as VM packages (particularly Parallels) are notorious for tricking the filesystem change history into not seeing all of the changes.


James, I just sent you a QRecall report a short while ago that you can probably now ignore. I have an action set to backup my VM folder after Fusion quits. The action was running, but not finding anything to archive. I suspect your tip will solve my problem. I just turned on the Deep Scan option for that action, but QRecall is in the middle of backing up my entire volume, so I can't test this right now. I'll give it a shot tomorrow and let you know if it worked.


It didn't help. In looking at it further, I think I know what's going on, but I'm not sure if I've found a bug, or I'm just not understanding how exclusion works in QRecall 2.0.

I have two separate archive files: one called "iMac 24.quanta" which is my main backup file. The second one, called "Virtual Machines.quanta" is used to backup my Virtual Machines folder. Usually, that's for VMware Fusion, but on occasion, I have VirtualBox files in there too. The settings for the "iMac 24" archive has all the checkboxes in the Exclude section checked, but nothing listed in the box where custom locations can be added. The settings for the "Virtual Machines" folder are exactly the same in that respect.

Now, the "Virtual Machines" folder on my hard drive has QRecall capture preferences -- the "Do not capture" button is the only one selected.

I have one action to capture my entire hard drive, and a separate action, on a different schedule, to capture my home folder. Both capture to the "iMac 24" archive. Neither of those actions captures my Virtual Machines folder, AS EXPECTED, since it has a "do not capture" preference. I have a third action, scheduled to run one minute after Fusion quits, for which the specified action is to capture the "Virtual Machines" folder to the "Virtual Machines" archive. That's the one that isn't capturing anything. In looking closely at the log, I see this:

Action 2015-11-06 09:27:01 Minutia Capture to Virtual Machines.quanta
Action 2015-11-06 09:27:01 archive: /Volumes/iMac 24 Backup/QRecall Backups/Virtual Machines.quanta
Action 2015-11-06 09:27:02 Capture Virtual Machines
Action 2015-11-06 09:27:02 Macintosh SSD:/Users/bgiles/Documents/Virtual Machines/
Action 2015-11-06 09:27:03 Excluded items
Action 2015-11-06 09:27:03 Folder Virtual Machines
Action 2015-11-06 09:27:03 Captured 0 items, Zero KB
Action 2015-11-06 09:27:03 captured: Zero KB (0 bytes)
Action 2015-11-06 09:27:03 written: Zero KB (0 bytes)
Action 2015-11-06 09:27:03 duplicate: Zero KB (0 bytes) 0.00%
Action 2015-11-06 09:27:03 rate: Zero KB/min
Action 2015-11-06 09:27:03 files: 0
Action 2015-11-06 09:27:03 folders: 0
Action 2015-11-06 09:27:03 icons: 0
Action 2015-11-06 09:27:03 Nothing Captured
Action 2015-11-06 09:27:03 There was nothing new to add to the archive.
Action 2015-11-06 09:27:03 ------- Capture finished (00:01)

It seems pretty clear from the log that it's not capturing the folder because it's excluded (by the capture preference). But I thought b20 (which is what I'm running) had a bug fix that was supposed to allow that when I was specifically trying to capture a folder that was ordinarily excluded. If so, that's not working. Or did I misunderstand?

I suspect the better solution, given my archive setup, is to delete the capture preference, and add an exclusion for the Virtual Machines folder to my "iMac 24" archive only. Then my regular backups should skip the folder, but my Virtual Machines capture action will get it, because it's capturing to a different archive which doesn't have an exclusion for the folder in the archive settings. Do you agree?

Also, as I was writing this message, I was opening and closing archive windows, as well as the Help window. When I closed one of the archive windows, QRecall quit on me. I submitted the bug report to Apple, and as soon as I post this message, I'll submit a report to you as well.
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1546
Offline

Bruce Giles wrote:I have two separate archive files: one called "iMac 24.quanta" which is my main backup file. The second one, called "Virtual Machines.quanta" is used to backup my Virtual Machines folder. Usually, that's for VMware Fusion, but on occasion, I have VirtualBox files in there too. The settings for the "iMac 24" archive has all the checkboxes in the Exclude section checked, but nothing listed in the box where custom locations can be added. The settings for the "Virtual Machines" folder are exactly the same in that respect.

Now, the "Virtual Machines" folder on my hard drive has QRecall capture preferences -- the "Do not capture" button is the only one selected.

From this description, I can tell you that your "Virtual Machines" folder will never be captured.

The crucial setting you set in both of your archives is the "Exclude: Individually Excluded Items" option. This setting honors the "Do Not Capture" preference you set on individual filesystem items. With the "Do Not Capture" preference set on your "Virtual Machines" folder, that folder won't ever be captured.

You have a couple of choices. Probably the simplest is to uncheck the "Exclude: Individually Excluded Items" option of your Virtual Machines.quanta archive. The iMac 24 archive will exclude everything you've individually set to exclude, while Virtual Machines will ignore that capture preference and capture them all.

It seems pretty clear from the log that it's not capturing the folder because it's excluded (by the capture preference). But I thought b20 (which is what I'm running) had a bug fix that was supposed to allow that when I was specifically trying to capture a folder that was ordinarily excluded. If so, that's not working. Or did I misunderstand?

That exception only applies to the "Ignore Changes" preference. Excluded items are always excluded, and should be logged as such.

I suspect the better solution, given my archive setup, is to delete the capture preference, and add an exclusion for the Virtual Machines folder to my "iMac 24" archive only. Then my regular backups should skip the folder, but my Virtual Machines capture action will get it, because it's capturing to a different archive which doesn't have an exclusion for the folder in the archive settings. Do you agree?

Dealer's choice, but I'm inclined to agree. My philosophy on this is:

  • Add items to the exclusion list of the archive when those exclusions are for the benefit of that archive, and that archive alone. For example, an archive that is focused on a particular subset of files (say, working projects) and you want to hone that focus by excluding extraneous items.

  • Add items to the exclusion list of the archive when the filesystem the items are on doesn't support extended attributes or there's a chance that the item could be deleted and recreated (which might discard the capture preferences attached to the original item).

  • Check the "Individually Excluded Items" option and use the capture preferences to conveniently exclude items from multiple archives. It's easy to change what items are excluded (no need to open the archive) and it applies to all archives.

  • If you have one or more "hot" archives that capture only important files on a regular basis (2 minutes after documents changed, for example) and a second "comprehensive" archive that captures everything (say, once a day), then use capture preferences to exclude the less interesting files from the "hot" archives and uncheck the "Exclude: Individually Excluded Items" from the "comprehensive" archive. The quick captures during the day will exclude items marked "Do Not Capture" and the daily capture will capture them anyway.

  • In this last scenario, you may find that there are items you never want to capture, ever. That's what the "Exclude from all archives" capture preference option is for. Even if an archive is set to capture "Do Not Capture" items, this option overrides that setting and excludes the item anyway.

  • Or, to paraphrase Uncle Ben from the Amazing Spiderman: "With great flexibility comes great confusion."

    - QRecall Development -
    [Email]
     
    Forum Index » Beta Version
    Go to:   
    Powered by JForum 2.1.8 © JForum Team