QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
[b23] small problems when restoring the system  XML
Forum Index » Beta Version
Author Message
Ming-Li Wang

Joined: 12-Jan-15 18:20
Messages: 78

I ran into two small issues when trying to restore the whole system partition with QR 2.0 beta for the first time yesterday. The restoration was done from a standby system (a bare minimum El Capitan system with QR 2.0 b23 and some other essential utilities installed) as I intended to restore the whole system partition.

The restoration was mostly successful, but QR said it failed at the end. The log registered two errors:

I tried to restore again for the user profile folder (Users/wang) and this time QR made no complaint. Trying to do the same with the CrashPlan.app however ran into the same issue. I ended up reinstalling CrashPlan after booting into the restored system.

The system has been running smoothly after restoration so there should be no problem. But I guess I should report the incident back to you. A diag report was filed right after the failure yesterday.

James Bucanek

Joined: 14-Feb-07 10:05
Messages: 1548

These are pretty minor issues, and certainly don't warrant the reinstallation of any software.

The CrashPlan.app error is a curious one, but probably inconsequential. The error indicates that during the recall QRecall was trying to restore the last modified date, creation date, last attributes change date, and the permissions (access mask) for the app bundle folder. For some reason, the operation was prohibited by the operation system. It might be the case that the Crash Plan app has a special ACL that prohibits changing one or more of these attributes.

But since we're talking about the app bundle folder, as long as it's readable that's just about all that matters.

The second error is equally mysterious, but also doesn't really matter. During the restore, QRecall determined that there were ACLs attached to the Documents folder, but the last time it captured the Documents folder there were none, so it tried to delete the ACLs. Again, this was prohibited by the OS for some reason. This might be a new behavior in 10.11 due to SIP. I'll have to look into it.

Overall, pretty trivial issues for a full restore of El Capitan.

- QRecall Development -
Forum Index » Beta Version
Go to:   
Powered by JForum 2.1.8 © JForum Team