QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Invalid parameter not satisfying: path!=nil  XML
Forum Index » Beta Version
Author Message
Ralph Strauch



Joined: 24-Oct-07 22:17
Messages: 194
Offline

Backing up my MBP over wifi to a drive mounted on my iMac failed this morning, with a "Invalid parameter not satisfying: path!=nil" message. I ran it again, and the second time it failed with "cannot open negative hash map."

Some background that may or may nto be relevant. My log shows a "Problem encountered while closing archive" at 1am on Sunday, that must have resulted when the iMac ran a scheduled backup because I had left the archive open on the MBP. That may be irrelevant, though, because both the iMac backup and a subsequent MBP backup later on Sunday both ran successfully.

James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Offline

Ralph,

The "problem closing archive" issue is probably unrelated. It appears that you left the archive open, and that computer later went to sleep, and while it was asleep some other process updated that archive, and when the first computer woke back up and tried to close the archive it found it in an unexpected state. Annoying, but by itself it doesn't mean anything bad happened.

The "invalid parameter" error is actually a red herring. The real problem happened a few seconds earlier when QRecall tried to duplicate the negative.index file. The copy failed with a "Timeout" error. This usually means the computer lost it's connection with the server, most like an interruption in WiFi.

That probably left the copy of the negative.index file half done, which explains the invalid negative hash map size error on the next attempt.

I suspect a simple repair (possibly even just a reindex) will fix the problem.

- QRecall Development -
[Email]
 
Forum Index » Beta Version
Go to:   
Powered by JForum 2.1.8 © JForum Team