QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
can't delete items sometimes  XML
Forum Index » Beta Version
Author Message
Ming-Li Wang



Joined: 12-Jan-15 18:20
Messages: 78
Offline

Very happy to see v2.1 in beta. I'm you'll beta 31 on macos 10.13.4.

First bug to report: QRecall sometimes has troubles deleting items from an archive, taking a long time waiting for the archive to close. (screenshot 1)

The dialog would say "complete" if I wait long enough, but it won't go away, and the "Stop" button would be grayed out and unclickable. (screenshot 2)

When that happens, QR has to be force-quit.

I've run into the problem numerous times with two different archives, so it doesn't seem to be archive-specific. I've deleted items from both archives successfully as well, so it seems random to me so far.

A report has been sent.

edit: the forum is acting funny and the 2nd attachment is shown on top.
[Thumb - 2.png]
 Filename 2.png [Disk] Download
 Description screenshot 2
 Filesize 41 Kbytes
 Downloaded:  6836 time(s)

[Thumb - 1.png]
 Filename 1.png [Disk] Download
 Description screenshot 1
 Filesize 40 Kbytes
 Downloaded:  7139 time(s)

This message was edited 1 time. Last update was at 22-Apr-18 01:19

James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1548
Online

Ming-Li Wang wrote:Very happy to see v2.1 in beta. I'm you'll beta 31 on macos 10.13.4.

Welcome aboard!

First bug to report: QRecall sometimes has troubles deleting items from an archive, taking a long time waiting for the archive to close. (screenshot 1)

Actually, it's waiting to open the archive. QRecall thinks that some other process might be using the archive and is waiting for it to stop. Sometimes, particularly if a process is on another computer, it can be hard to tell and QRecall will cautiously wait about 10 minutes before proceeding. If everything is working perfectly, this shouldn't happen as the last process should mark the archive as "not busy." Hopefully the report will have some clues.

The dialog would say "complete" if I wait long enough, but it won't go away, and the "Stop" button would be grayed out and unclickable. (screenshot 2)

This is a known bug that I'm still investigating. Basically, the QRecall application loses its connection with the command process at the last moment and gets stuck in a dialog because (a) it can't tell the command to stop and (b) it hasn't gotten a message from the command that says it's finished. Again, your report (and reports from others) should help figure this out.

I've run into the problem numerous times with two different archives, so it doesn't seem to be archive-specific. I've deleted items from both archives successfully as well, so it seems random to me so far.

You are correct, it is not archive specific, or even command specific; this can happen with any command.

A report has been sent.

Thanks.

- QRecall Development -
[Email]
 
Forum Index » Beta Version
Go to:   
Powered by JForum 2.1.8 © JForum Team