QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
exclude pattern not working  XML
Forum Index » Problems and Bugs
Author Message
Johannes



Joined: 10-Dec-10 09:54
Messages: 66
Offline

I was very happy to see the feature "exclude by expression" finally appear in the archive settings

But I can't get it to work. Perhaps I'm doing something wrong ...

I have an Archive backing up a certain Folder and I want to exclude mp3 files.
So I set up a a glob pattern like this
path: /Volumes/WorkingMedia/Sound room
Pattern: *.mp3
repetition: check

But when I capture the folder mp3 files are still included in the Archve.

What am I doing wrong?
Thanks in advance,
Johannes
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1434
Online

Johannes,

It looks like you're doing everything right, so I'm not sure why it's not working for you.

I just set up a similar test, capturing a folder on an external volume, excluding all of the *.dmg files, and it worked as advertised.

So here are my suggestions:

  • Make sure the path is correct

  • If you're typing in the path, it's easy to mess it up. Instead, select the path portion of the pattern, clear its contents, and then locate the folder in the Finder and drag that into the path field (the insertion cursor must be active for this to work). That will alway paste in the exact path to the folder.

  • Make sure the extension is correct

  • Select one of your .mp3 files, choose Get Info in the Finder, then look at the Name & Extension section. Make sure the extension is correct and it's really the extension of the file. (Some files have what look like extensions, but their extension is hidden in the Finder and the "extension" you see is actually part of its name.)

  • Verify where you are creating the pattern

  • You didn't mention whether you were setting this pattern in the Archive's settings or in the Capture Preferences of an item. When using the capture preferences, absolute paths are not allowed and if you create a pattern with an absolute path, it will be ignored. So you have the choice of adding the pattern to the archive's settings or using a relative path in a pattern attached to a folder:

    Archive Settings: path=/Volumes/WorkingMedia/Sound room
    Capture prefs for /Volumes/WorkingMedia/Sound room: path=(empty)
    Capture prefs for /Volumes/WorkingMedia: path=Sound room

    Finally, you also have the option of creating a .qrecall_exclude_patterns.txt file in the "Sound room" folder. It would consist of a single, simple, repeating, glob pattern:



    Let us know if any of that helps.

    - QRecall Development -
    [Email]
    Johannes



    Joined: 10-Dec-10 09:54
    Messages: 66
    Offline

    Thanks, James, for getting back to me.

    I tried all your suggestions – the result remains the same. QRecall keeps on capturing mp3 files.
    I used the patterns in the Archive settings (I did not know that this is possible with capture preferences as well)

    What worked was the .qrecall_exclude_patterns.txt file. This is a good solution for me. So the issue is solved for me.

    Let me know if you want me to do further testings ...

    Thanks,
    Johannes
    James Bucanek



    Joined: 14-Feb-07 10:05
    Messages: 1434
    Online

    I can't think of anything for you to test, but I do have a question. Are you capturing the entire volume/folder, or specific items inside of the "Sound room" folder?

    - QRecall Development -
    [Email]
    Johannes



    Joined: 10-Dec-10 09:54
    Messages: 66
    Offline

    I capture the entire folder "Sound room" (but some of the folders within have their capture preferences that to "do not capture")
     
    Forum Index » Problems and Bugs
    Go to:   
    Powered by JForum 2.1.8 © JForum Team