QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Scheduler version mismatch - RC1  XML
Forum Index » Problems and Bugs
Author Message
Steven M. Alper



Joined: 05-Mar-07 08:09
Messages: 55
Offline

James:

Installed RC1 and ran. It failed to quit the old Scheduler for the new. I force quit the old and relaunched. It appears (to me) that all is well.

Relevant portion of Log file follows:



Best wishes,


--

Steven M. Alper
James Bucanek



Joined: 14-Feb-07 10:05
Messages: 1546
Online

Steven M. Alper wrote:Installed RC1 and ran. It failed to quit the old Scheduler for the new. I force quit the old and relaunched. It appears (to me) that all is well.

Thanks, Steven.

This is caused by a bug in Apple's launchd. The problem is that the OS restarts the old scheduler even after the new one has been installed. I still don't know why or how to convince it to stop running the old scheduler.

As you've discovered, manually killing the old scheduler or just restarting fixes the problem. Hopefully by the time I get to next dot release I'll have a more elegant solution.

- QRecall Development -
[Email]
Steven M. Alper



Joined: 05-Mar-07 08:09
Messages: 55
Offline

I've gotten software upgrades that include an Applescript or Terminal script called something like "Run before installing new version" that handle things like that. (This I assume is based on the general reluctance to run a .pkg installer.)

You might consider something along those lines, failing the more elegant solution.

Yours,

This message was edited 1 time. Last update was at 29-Jan-08 10:04


--

Steven M. Alper
 
Forum Index » Problems and Bugs
Go to:   
Powered by JForum 2.1.8 © JForum Team