QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: Mats Jacobson
Forum Index » Profile for Mats Jacobson » Messages posted by Mats Jacobson
Author Message
James Bucanek wrote:
Each QRecall action is stored as an action file (.qraction) in the ~/Library/Preferences/QRecall/Actions folder inside your home folder. Each file is automatically named (e.g. important stuff-compact_0.qraction) in a way that should make it easy to identify what that action is.

If you have copies of your action files (say, in the archive that captures your home folder or still in your Trash), simply move/copy/restore them back to that folder and restart your system.

The quickest way to do that is to re-launch the QRecall app and the QRScheduler process. The later can be restarted using the Activity Monitor app; use the search field to find the QRScheduler process and tell it a "Quit" (a TERM signal,

This worked though it took a long time to accept run immediately. Thank you!
James Bucanek wrote:
I suspect you can solve this simply by launching QRecall and going to QRecall > Preferences. Choose the Authorization tab and check the "Capture and recall items with administrative privileges" option.

QRecall should then prompt for your administrator's account and password. If successful, it should install the privileged helper service.

Count to three, quit QRecall, and launch it again. If I'm right, everything should get reinstalled and start working again.

If I'm wrong, you know how to send another diagnostic report...

I couldn't do any of that as QRecall hung no matter what I tried to do. I attempted a detailed uninstallation followed by a new fresh installation after a restart and while I now get QRecall 2.1.8 properly opened I lost my schedule Actions for the main archive. Are these possible to recreate? I still have most files I think. Are the actions saved somewhere in them? I can open the archive, but that's it as far as I can see.
James Bucanek wrote:Mats,

Let's start by getting a diagnostic report. Open QRecall and choose Help > Send Report from the menu.

report sent.
Since a few weeks, since 2.1.7 I believe and now 2.1.8, also after a clean re-installation and multiple restarts Qrecall cannot connect to the Scheduler. QRecallScheduler and QRecallSwitchboard are running according to Activity Monitor.

After the clean re-installation Qrecall Monitor the app doesn't seem to run. I can start it from within the QRecall app and it will run, but nothing works even still.

In Console I see a few "Uncaught Exception was raised" and some <private> entries. The log says "Install command failed" multiple dates. I uninstalled and made a clean installation (left preferences intact) from 2.1.8 image and restarted the system. Didn't help.

macOS 10.12.6 Sierra. SiP is inactivated. is this a known problem? What can be done here?
James Bucanek wrote:Mats,

It’s difficult to guess what’s going on here. If you haven’t already, send a diagnostic report (Help > Send Report).

OK, just did. Please respond here.

James Bucanek wrote:
Is this a local (directly connected) volume?

FireWire disk. It's a removable 1TB Western Digital Green.
First I get this in Capture in the log:
"Action 2014-08-15 16:25:41 The layer created by this capture is incomplete and may be missing items. Use caution when recalling items in this layer. "

Then later I have in one item "Action2014-09-04 14:26:28 Failure Unable to start LS API isolation process; will use local process "

Action 2014-09-04 14:26:33 Curious Could not determine display name
Action 2014-09-04 14:26:33 cannot get display name
Action 2014-09-04 14:26:33 Error: Unexpected internal error
Action 2014-09-04 14:27:44 Library/Application Support/FXpansion/Tremor/System/Presets/Factory/Drums
Action 2014-09-04 14:27:44 Percussion
Action 2014-09-04 14:27:41 file Bongo rez H.tremordrum
Action 2014-09-04 14:27:41 Failure Could not capture file
Action 2014-09-04 14:27:41 failed to write envelope header
Action 2014-09-04 14:27:44 file Bongo riz H.tremordrum
Action 2014-09-04 14:27:44 Failure Could not capture file
Action 2014-09-04 14:27:44 folder Percussion
Action 2014-09-04 14:31:40 Failure Failed
Action 2014-09-04 14:31:40 archive I/O error
Action 2014-09-04 14:31:52 Failure Capture failed
Action 2014-09-04 14:31:52 A storage or disk error occurred while writing to the archive data. This could indicate a hard drive failure, or the drive or volume was disconnected. The archive may need to be repaired.
Action 2014-09-04 14:31:52 ------- Capture incomplete (06:29)

Note that those files exists.

QRecall 2014-09-05 18:51:29 Warning Unexpected file system error
QRecall 2014-09-05 18:51:29 Error: Error removing
QRecall 2014-09-05 18:51:29 Path: /Volumes/Safe House/Dagligen/dagligdags.quanta/.lock
QRecall 2014-09-05 18:51:29 Failure Problem recovering from failed attempt to open archive
QRecall 2014-09-05 18:51:29 could not remove lock file
QRecall 2014-09-05 18:51:29 Error: package 5 not present / Invalid argument
QRecall 2014-09-05 18:51:29 Message: [NSFileManager removeFileAtPath:handler:]
QRecall 2014-09-05 18:51:29 Warning Unable to open document dagligdags.quanta
QRecall 2014-09-05 18:51:29 path: /Volumes/Safe House/Dagligen/dagligdags.quanta
QRecall 2014-09-05 18:51:29 docType: com.qrecall.repository
QRecall 2014-09-05 18:51:29 could not remove lock file
QRecall 2014-09-05 18:51:29 Error: package 5 not present / Invalid argument
QRecall 2014-09-05 18:51:29 Message: [NSFileManager removeFileAtPath:handler:]

Checking the disk gives no errors. I also tried Drive Genius.

And when running cat in the archive that gives this uplifting result:

archive.quanta user$ cat * > /dev/null && echo "No read problems"
No read problems

Is this a real error or just some missing or unreadable file on my originating HD? I can't delete the .lock file with "sudo rm" either.
Forum Index » Profile for Mats Jacobson » Messages posted by Mats Jacobson
Go to:   
Powered by JForum 2.1.8 © JForum Team