QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: Prion
Forum Index » Profile for Prion » Messages posted by Prion
Author Message
I am watching the situation carefully but amazingly (or perhaps expectedly) it seems to work just like it should.
Thank you, helpful as ever!
Hi James

neat, I had not thought of that. I'll try this hack and report back. Thanks for the suggestion!
can I make sure that a USB volume with the Recall archive is mounted before trying to access it?

The archive sits on a USB3 drive connected to a Mac mini. The Mac mini is in the same Wifi as my laptop which is the computer that is to be backed up. The idea behind this is that capture actions are running on the laptop, but all the maintenance action (merge, verify etc) are carried out on the Mac mini and are thus much faster than via Wifi.

Currently I have to make sure that the USB drive is accessible and I would like to automate this step, every thing less to worry about (or forget!) is good for backups.

An addendum:
After having copied the Archive status window it would show both logs for the same archive, at the old and new location. The old one made the status indicator blob turn yellow after a while because unlike the archive at the new location it hadn't been updated in a while. Since I did not plan to use the archive at the old location ever again I needed to make the archive forget about where it had been located before.
Right-click inside the window showing the status at the old location, click "forget" and the blob is clear again.
I have been using QRecall for the last years exclusively for my backup needs and it still surprises me. Today I copied my archive to another drive and braced myself to edit all my various scheduled actions to use the new location for the archive now. After editing the first one there was a popup, simply stating something along the lines "you have another 8 actions using the same archive, do you want to use the new location for them as well?"

A little detail only, perhaps, but in my years of usage I have come to appreciate that this attention to details reflects the overall attitude towards crafting every aspect of this software.
One of my best purchases and one I would do again without hesitation.

Err, that was all
Dear James
simple as that: does QRecall run under Yosemite? I would delay upgrading to OS X 10.10 if it meant breaking my backup strategy using QRecall.

Best regards
As an addendum: Verify worked fine, but later I merged again the now incomplete, more inclusive layer and its subsequent layer - same result. Then merged three layers, the one before, the incomplete and the one after - still incomplete but no error message.

Hi James
I am having the following problem. During the acquisition of a new layer QRecall ran out of space and hence the process was terminated with an error message.
The archive was damaged and couldn't be opened until I repaired it which worked fine (phew).
I noticed there was an incomplete layer which I merge with the one that followed. The result was that I now have a more inclusive, larger layer which still is incomplete. I repeated with the next layer, same result. I am not totally sure that it has not been there before the error occurred, it possibly has been without me taking notice.

Any ideas what to try next? Ultimately, I am not too worried because the layer is quite old, but I would like to make sure that I have at least one copy of each item inside the incomplete layer that resides in apparently intact layers. (Verify is currently running).


I am now using the latest beta and have noticed an error message along the lines of "unable to read extended attributes...."
The backup seems to have run fine though. Searching for this error message on this forum did not turn up any results but I assume this is harmless. Correct?

Hi James,

I did not make myself clear then, what I meant was why enabling TimeMachine may have conflicted with QRecall, possibly the fact that both running simultaneously and/or that the USB drive is connected to the TimeCapsule may play a role here though I have not idea *how* exactly this may have been a problem. I did not mean to ask about incomplete layers, sorry about the confusion.
I definitely did not run out of space, on both hard drives there is more than 200 GB of free space available.

The problems started exactly the day I re-enabled TimeMachine, I checked the TimeMAchine sparsebundle.

Good point about merging the incomplete layers with the next complete one, this will make the archive look a bit more tidy, I do not think there are valuable intermediates that need to be preserved. Out of curiosity, if QRecall gets interrupted in the midst of dealing with one particular file it will resume its activity by starting over again at this particular file, right? It will not somehow miss the bits it has started to do but forgotten because it was interrupted?

Some things have changed now.

The header problems for the QR volume on the USB drive could be solved
The QR Archive on the USB drive could be repaired using the auto-repair data associated with it (Don't you just *love* it when a problem arises, and only after you had that brief moment of realization that you'd be lost had you been left to your own devices you are introduced to that magical fall-back position and it all resolves into sweet nothingness)
There was an unused mountpoint in the volume folder which was a beast to get rid of. I suspect that it was ultimately the reason that QRecall could not access its archive because the drive now had a trailing "1" after its name. "Drive in use" error message all over the place. History anyway.

Whatever detail it was, everything is working again now. For now, the USB drive is connected to the MBP directly and TimeMachine is disabled. I'll await your comments on how to proceed regarding
1) coexistence of TimeMachine and QRecall
2) connecting the USB drive to the TimeCapsule.

Thanks for your support! The longer I work with QRecall the more I realize just how much consideration and attention to detail went into its creation. I am trying to avoid this situation but if I'd be forced to make a choice between TimeMachine and QRecall, I'd ditch the former. Still trying to avoid this situation though but that's how good I think QR is.

there are several incomplete layers of capture after a certain date. I was racking my brain what may have changed and I think I know now. At that day I re-enabled TimeMachine attached to which the USB drive with QRecall's archive is running.

Repairing the QRecall volume revealed a minor header problem which was corrected (according to Disk util).

What shall I do with the incomplete layers? Delete them? Assuming for now that the TimeMachine backup will contain all the changes since then I think I could live without them. Apparently it was not such a good idea to have TM and QRecall as a dual backup solution, at least not in this configuration.

1) Any ideas what may have caused the problem technically and how to avoid this in the future?
2) QRecall can backup over WiFi, can it not?
3) Delete the incomplete layers? Or do they still contain valuable information?

It seems I am still having problems. The archive that I have used over the last months cannot be written to any longer. It is not a simple permission issue (the archive resides on a USB drive), because a test archive could be used on the same drive with no problems.
The error message says:
Cannot convert FSRev to Path
And consequently:
A network or disk error was encountered

I cannot verify the archive, either, because:
cannot open a negative hash map.

There may be a simple thing causing all this but I am at a loss.

Hi James,

ah, bummer, although I half expected that. Does the same hold true for the TimeCapsule itself? Never tried that one because it keeps being used for TimeMachine backups of the family's laptop.

Regarding the extended attributes I must admit I never noticed the little details slider in the upper right corner of the log window. It helps a lot to pull it all the way to the right

It reads:

errno: 1

There is no particular file or folder mentioned, so it seems to be a more general thing.
Can you deduce something from this?
Meanwhile I will repair the volume.
Thanks for getting back to me

I have a problem getting QRecall capturing to a USB drive that is plugged into a TimeCapsule. I have pre-authorized QRecall and can capture to this drive when I plug it into my MBP directly, including when logged out. However, when I plug it into the TC, the following happens:

- QRecall cannot find the archive when I try to capture to the drive connected to the TC while logged out
- when logged in, the capturing takes place normally, however, the log specifies that "Unable to read extended attribute data". This does not happen when plugging the drive directly into the MBP

Is both to be expected and can or should anything be done against it?


I am somewhat new to this and would like to set up two different capture strategies that would
1) capture the entire system, preferrably overnight after which the system would be put to sleep or switched off
2) capture whatever might be worth capturing in terms of data in my user's space (Documents, Pictures, Movies, Music, etc.)

Ideally these would require little or no intervention to run after their initial setup. My main machine is a 15 inch MBP and I have two different external harddrives for the two tasks, for task #1 USB2 drive in an inclosure and for task #2 a Fw800 3.5 external HDD. Both are 500GB drives. In principle there is also a TimeCapsule 1TB that I am curently using for my TimeMachine Backup. The USB2 drive for the system capture contains a minimal Snow Leopard installation plus QRecall as the only program.

Question 1:
I imagine that capturing software while it is running is asking for trouble, so presumably I would need to be running a different operating system of the same type (10.6 in my case running on the 2.5 USB drive) to backup my main harddrive in the MBP. Likewise, I would need to be logged out for capturing my user data (task #2). Correct? How do I set this up then?
If so, this would limit my backup frequency in particular for task #2 because I would then let it run at noon and at night. Perhaps that is sufficient but I don't know. How do you handle this? I cannot imagine logging our every hour for my backup to take place.

Question 2:
Can I rename a drive that I previously captured data to with Qrecall and still continue capturing data to or restoring data from?
Can I copy the content of the 2.5 drive to another drive (with a different name) and use that drive to boot from? I would assume that I would need to use CarbonCopyCloner to keep the new drive bootable (or can I use Diskutil?).

Question 3:
Playing around with the TimeCapsule it seems as though QRecall is perfectly willing to accept an external harddrive connected to the TimeCapsule's USB port.
At least while I am at home (near the TCapsule) I would prefer to archive to that disk because then I would not need to connect and unconnect the drives used for backup.

Question 4:
I am unsure if I should include the user data also in the system backup to have some redundancy or if that just fills the thing up too quickly. Since I cannot easily prune the user data if I find that the case it might be worth asking you pros here.

Question 5: What do I need to do to ensure that my backup is safe on the one hand but that I will be able to restore a backup and not fail because of insufficient privileges over the files to be restored?

I know, many questions and I would appreciate your help very much

Forum Index » Profile for Prion » Messages posted by Prion
Go to:   
Powered by JForum 2.1.8 © JForum Team