QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: Ralph Strauch
Forum Index » Profile for Ralph Strauch » Messages posted by Ralph Strauch
Author Message
Here are those listings, with some explanation.

The first listing is from a folder containing only the archive, 3rd which I had moved to a separate folder because it felt like the router would be easier to configure if the shared file was in a separate folder than if it was at the top level.

The second listing is from the volume containing my test archive, named testbackup.quanta. When I saw the hidden files that this directory contained I thought maybe that was the problem -- that when I moved 3rdbackup.quanta into a separate folder I had not move some invisible file that it needed in order to open. So I moved it back to the top level of that volume.

That didn't solve the problem. testbackup.quanta will open properly, but 3rdbackup.quanta hang with the "file in use" message.


First listing: 3rd backup.quanta in a separate folder/volume2/backup


2nd listing: directory containing testbackup.quanta at top level



third listing Directory containing 3rdbackup.quanta returned to top level in /volume2
After three weeks away, I'm back again trying to get Qrecall to work with my new router. I'm now able to see, read, and write to disks mounted on the router. My regular archive still won't open, though, but still continues to hang with the "This archive is being updated ..." notice and never obtains the semaphore lock. I was able to create a small test archive, though, which closes and reopens normally. The problem seem to be just with the larger archive. I'm sending a Report.

Ralph
An archive is organized by owners (define by identity keys), which contain volumes, which contain files and folders. If your identity key changes QRecall treats your files as if they were from a completely different computer and recaptures them all. These new files will be contained within the new owner and volume at the root of the archive.


I originally purchased two identity keys to use one for each computer, but didn't keep track of which was which. As some point in my wrestling with the new router, Qrecall said I didn't have an identity key and needed to reinstall one. I picked the wrong one so ended up with the same key on both machines. I think I've that sorted out now, and am back to one key per computer. I assume I can just delete the extra layer that I created unintentionally without affecting the rest of the backup

The capture action is crashing trying to encrypt data. Try setting your Concurrent Encryption Limit setting to 1 and run the capture again. Meanwhile, I'll fire off another blistering bug report to Apple.


I had set the Current Encryption Limit to 2 after you suggested 1 or 2, but I'll take it down to 1 now.

Honestly, I would hope that you can get this working on your router. If it's possible for all of the QRecall clients to connect to the router with the same authentication, they should be able to peacefully share the single archive.


I'm backing up two computers to the same archive, a MBP and an iMac. I'm the sole user of the MBP and back it up from my account. My wife is the primary user of the iMac and I've been running that backup from her account. I seldom even log onto the iMac, but it looks like Qrecall could run scheduled backups of the whole iMac from my account without my being logged in. Is that correct, and should that satisfy the router's desire for a single common user? (I'm uid 501 on both machines.)

One final item -- my archive now won't open from my wife's account on the iMac, even though it opens fine in my iMac account and on my MBP.

I'm off to a week in the desert tomorrow or Sunday, so may not get back to this till next year. Thanks again for all the hand-holding you provide. I really appreciate it.

Ralph
I've now mounted the backup drive directly on the MBP and run a backup there, which took almost 11 hours and created a new layer containing 204gb, which is about 10x what I would have expected. The Qrecall log did not record the completion of that backup. The drive being backed up contains 360GB and the archive now shows in Finder as 713GB. This is about what it was before the backup, so I'm not sure where the new layer went. It's somewhere, though, because I can see it when I open the archive, and can restore files from it, (I should have been making notes during this process, but wasn't.) The new layer contains files that haven't changed in years, so I don't know what criteria Qrecall was using for changed files.

At this point my best solution may be to return my new router and go back to my old system, so my only questions now are where the 204gb backup went and if the fact that it doesn't show as completed in the log is anything I should worry about?

When you look at my report you'll find a number of failed "waiting for archive" backup attempts. I caused those by trying to run a "backup to router" action while the drive was mounted on my computer, and not realizing why it wasn't going through.
I don't think that solution will work for me. because I also capture my wife's iMac to this same archive from her user account, I think it's more than a permissions problem, though, because I can open and change other files on the same drive. The Qrecall archive is the only file that won't open, so perhaps the problem is somehow with the archive's structure.

The router apparently does not support MacOS file versions, because when I edit a text file in TextEdit and save it, I get an error message that says:

The document “focusing_your_touch1.txt” is on a volume that does not support permanent version storage.
You will not be able to access older versions of this document once you close it.


The file does save, though.

I'll give TP-link support a try and see if they have any ideas. Is there anything in particular that it might be useful to tell them about the archive?

Ralph
OK, this time I got a "permission denied."

[cpe-172-248-32-105:/Volumes/volume2] ralph% cd '/Volumes/volume2/3rd backup.quanta'
[cpe-172-248-32-105:/Volumes/volume2/3rd backup.quanta] ralph% touch .semaphore touch: .semaphore: Permission denied
[cpe-172-248-32-105:/Volumes/volume2/3rd backup.quanta] ralph% rm .semaphore
rm: .semaphore: No such file or directory

Is changing that permission something I can do in a way that will stick, or do I need to ask the router people for a change? And if so, what specifically should I ask them for?
I ran the commands you suggested and get no error messages, but still cannot access the archive

[cpe-172-248-32-105:~] ralph% cd /Volumes/volume2
[cpe-172-248-32-105:/Volumes/volume2] ralph% touch .semaphore
[cpe-172-248-32-105:/Volumes/volume2] ralph% rm .semaphore
[cpe-172-248-32-105:/Volumes/volume2] ralph%

The permissions for both the archive and the volume containing it show up in Finder as "custom access," and in terminal as

[cpe-172-248-32-105:/volumes/volume2] ralph% ls -l
total 4160
drwx------ 1 ralph staff 16384 Dec 18 03:10 3rd backup.quanta

but I don't understand Unix permissions well enough to know If that's something I should try to change that or not. I also notice that I'm apparently running a shell provided by the router, rather than one from my computer. When I run terminal with the router disconnected I get "[Ralphs-rMBP:~] ralph%" and as soon as I connect to the router it changes to the one above.

Maybe it's time for me to take this to the router's support group. Is there anything else I should tell them about the problem that might help solve it from their end?



After repairing my archive I copied the archive back to my reformatted drive and mounted it on my new router. I can now see the drive in the Finder, but Qrecall doesn't seem to be able to connect to the archive. When I try to launch a backup from the action menu, the Monitor Window show "opening archive" or "waiting for archive" and goes no further. If I just to open the archive from the File menu or by clicking on the archive I get a "waiting for archive" window or sometimes just a spinning beachball requiring a force-quit.

Apparently this is a result of the way router presents the file to Qrecall. The disk shared through the router doesn't show up as a device is Finder, but is accessed through Go/Connect to Finder where it shows up as an smb:// connection to my ISP's router. That connection shows up in Finder as a Volume, listing the contents of the drive. I can open most of the files listed, but not the archive.

Is there a way to connect to this router that will work with qrecall, or do I just have to go back to my previous setup of mounting the archive directly on my iMac? The router, if I can make it work, will give me a USB3 connection instead of the USB2 connection the iMac provides, and hopefully be more reliable than my previous router connection has been.
After my encryption completed I compacted the archive, which created a problem requiring a repair. The repair logged several additional problems, but eventually completed successfully. I'm back in business now and everything is fine, but I'm sending this report in case any of the diagnostic info is of value to you. I don't need any response.
As always, your advice is spot on. My archive is now encrypted and I'm back in business. I'm switching over to archives encrypted by qrecall from unencrypted archives stored on FileVault encrypted drives so that I can share the backup drive through a new router that will hopefully resolve the intermittent problems I've been having with network backups for the past couple of years.
I seem to have gotten myself into a box that I can't see how to get out of. I decided to encrypt a 700gb archive on a 2tb drive with about 1.2gb free space, which seemed like plenty to allow the encryption. The process quit on me a couple of times, but I was able to restart it without difficulty. When I was ready to go to bed at about 11pm it still had a ways to go, so I triggered a backup action thinking that it would start after the encryption completed. I got up this morning to find that the backup had apparently run immediately, stopping the encryption in the process. When I tried to restart the encryption I got an "Insufficient free space to duplicate archive" error, because the partially encrypted archive size is now 1.2tb and I have less than 600gb free space.

What's my best course forward at this point? I assume that the archive is as big as it is because it now contains both unencrypted and encrypted data. Would merging layers or compacting the archive clean it out to the point that I could continue the encryption?

Ralph
I store my archives on two encrypted drives, rather than encrypted disk images, and that works fine. The drives are encrypted using disk utility and I store the passwords in the iMac keychain, so the iMac can open and mount the drive for backup, without manual intervention. One drive is always stored offsite and is fully protected while it is.

Ralph
This is a update on the intermittent "problem closing file" issue I've had with qrecall v2. It only happens when I back up my MBP over wifi to a backup drive mounted on an iMac, and it has occurred with two different backup drives so seemed to be a network problem.

I eliminated the wifi connection by shutting off wifi and connecting the two computers via firewire, which took care of the problem but makes backing up more cumbersome. Then a couple of weeks ago it occurred to me that when I connected the computers that way I was also waking up the iMac, which a wifi backup didn't always seem to do, so I decided to try wifi backups while keeping the iMac awake with the Caffeine utility. That seemed to work as well, with both backup drives, and while still inconvenient, is less trouble than moving the MBP into the same room with the iMac and physically changing the network connection.

Today I decided to try wifi again and again got the error, so I followed up immediately with a backup over firewire. I then noticed that the earlier wifi backup had apparently completed, and added a layer to the archive even as it was complaining about a "problem closing file." (I've also noticed this occasionally in the past.)

I've been using qrecall since 2007 and this problem only cropped up with v2, so I'm guessing that something in v2 changed what happens with the wifi connection when the target computer is asleep.

Ralph
I'm still having intermittent, but fairly frequent, problems when backing up my MBP over wifi to a backup drive mounted on my iMac. It seems to be a network problem of some kind, but my network connection otherwise seems strong and the problem didn't really start until I installed Qrecall 2.0. Can you tell anything about what's causing it from my logs, and do you have any suggestions about how I might control it?

I've sent a report showing recent problems. The repairs and subsequent good backups after the failures were done with the backup drive mounted directly on the MBP.

Ralph
OK, thanks for the fast response. I'm running a repair right now, and hope that won't create any new problems. I'll hold off on any backups till I get the new version.
 
Forum Index » Profile for Ralph Strauch » Messages posted by Ralph Strauch
Go to:   
Powered by JForum 2.1.8 © JForum Team