QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: Charles Watts-Jones
Forum Index » Profile for Charles Watts-Jones » Messages posted by Charles Watts-Jones
Author Message
I have set QR on my Macbook Pro (10.6.8) to run on connection of the external drive and every 12 hours thereafter.

A recent back-up stopped with a 'low grade' error message to the effect that QR couldn't back certain files up - apologies for the lack of the precise wording, I didn't screen dump that message and don't have the Macbook with me at the moment. I was in a hurry so I reran the back-up and all completed correctly. When I looked in the log later, the error was flagged with a blue 'i' when I would have expected a red 'x'. And the detail provided when I expanded the log, was small, it certainly didn't identify where the problem had arisen. The impression this gave was that QR didn't consider the failure to be more than a minor event, to me it might have have been serious especially if the second back-up run had failed. Worth considering upgrading the importance of such messages?
James Bucanek wrote:The principle improvements in QRecall 1.2 are more efficient use of the quanta and packages indexes, expanded RAM usage (thanks to 64-bit addressing), and multi-processor load balancing. These changes improve capture performance the most, and impact compact and merge actions to a lessor degree.

Had a quick check in the log. Version 1.1.4 captured 1.12 GB (75% duplicate) in 12:53 while the beta managed 1.15 GB (73% duplicate) in 09:56. Looking good.
Having installed on a late 2007 iMac (iMac7,1) running 10.6.3 with 4 GB RAM, I turned off scheduled wake-up in Energy Saver and asked QRecall to wake and then sleep machine on completing its tasks. Worked flawlessly - great! I didn't however noticed a faster Verify (1:07:12 for a 237.6 GB archive) than I got with QRecall 1.1.4. Don't know if I should have expected this(?).
James Bucanek wrote:
An interval schedule (like every 3 days or every 90 minutes) is based on fixed time intervals from a particular point in time. You selected 28-Jul-2008 7:10 as your anchor time. QRecall then calculates 72 hour intervals from that time.

Unfortunately, 7:10 in July is an hour different from 7:10 in January because daylight savings time shifts the clock between summer and winter. QRecall is calculating an exact number of 72 hour intervals from 28-Jul-2008 7:10 and that occurs at 6:10 this month.

OK I understand this and even suspected it though it doesn't explain why two verifies (2 & 5 January) started at 6:55. Or does it?, it's too late here to do the maths.

James Bucanek wrote:
I'd suggest using a Daily schedule and choose two days a week to perform the verify.

I'll try this. By the way my own machine uses the same verify routine and has had no troubles (so far as I'm aware). Crazy world, eh?
Here's the schedule (upload failed earlier).
My wife's iMac running 10.6.1 is set to run a back up sequence every morning at 7.00, the sequence includes a verify three times/week. This morning the verify started at 6.10 (and woke up my dog), the rest of the back-up started on schedule. Checking the log I see that verify has started before the back-up sequence several times. The attachments should should this odd behaviour. Any ideas on how to get verify to start on time (and let my dog sleep a bit longer)?
James Bucanek wrote:Well, it appears from your log that everything was reinstalled correctly but your scheduler still isn't getting started when you start up. Why I can't say. Launch your Console application and look in your console and system logs for anything from the QRecallKicker (just search for "qrecall"). If you find any messages, send them to me. If you don't, I'll send you a special version of the QRecallKicker daemon that logs extra detail to the console log.

I didn't see anything from QRecallKicker, here are the QRecall messages (console & system):

11/08/2009 18:57:46 com.apple.launchd[129] (com.qrecall.monitor[169]) Exited: Terminated
11/08/2009 19:11:18 [0x0-0x28028].com.qrecall.client[229] No matching processes belonging to you were found
11/08/2009 19:22:53 [0x0-0x95095].com.qrecall.client[462] launchctl: Error unloading: com.qrecall.scheduler
11/08/2009 19:22:53 [0x0-0x95095].com.qrecall.client[462] No matching processes belonging to you were found

Aug 11 18:57:46 CharlesBook com.apple.launchd[129] (com.qrecall.monitor[169]): Exited: Terminated
Aug 11 19:10:57 CharlesBook authexec[238]: executing /Applications/QRecall.app/Contents/Resources/QRecallHelper
Aug 11 19:11:18 CharlesBook [0x0-0x28028].com.qrecall.client[229]: No matching processes belonging to you were found
Aug 11 19:22:53 CharlesBook [0x0-0x95095].com.qrecall.client[462]: launchctl: Error unloading: com.qrecall.scheduler
Aug 11 19:22:53 CharlesBook [0x0-0x95095].com.qrecall.client[462]: No matching processes belonging to you were found

Two quick questions: Do you have your system configured to auto-log in, or boot to the login screen? And is your /Users folder on a different partition than your main /System folder?

All my machines boot to the login screen and the /Users are on the same drive & partition as the /System folder.
James Bucanek wrote:
But some things still seem confused. I'm going to suggest that you (almost) completely uninstall QRecall and set it up again. This will require two restarts, so do it when it's convenient:

1. In QRecall > Preferences > Authorization, uncheck the option "Start and run actions while logged out."
2. Hold down the Option and Shift keys and choose the QRecall > Quit and Uninstall command.
3. Trash any files beginning with com.qrecall from the /Library/LaunchDaemons, /Library/LaunchAgents, and ~/Library/LaunchAgents folders. (Do not attempt to empty the trash yet.)
4. Trash the /Library/Application Support/QRecall and the ~/Library/Application Support/QRecall folders (if they exist).
5. Restart your computer. (Now you can empty your trash.)
6. Launch QRecall.
7. In Preferences, pre-authorize QRecall to use Administrative privileges.
8. Check the option "Start and run actions while logged out."
9. Restart your computer.

After all of that, log out and back in at least twice (there's no rush) and then send me another diagnostics report.


Followed instructions to the letter. Report now sent. FYI there were no com.qrecall files in the /Library/LaunchDaemons, /Library/LaunchAgents, and ~/Library/LaunchAgents folders. While the /Library/Application Support/QRecall and the ~/Library/Application Support/QRecall folders existed, they were empty.
James Bucanek wrote:I'm not sure what's wrong, but your system is not behaving correctly and I don't know why.

When you install QRecall to run actions while you're logged out, it installs the QRecallScheduler as a system-wide user agent in /Library/LaunchAgents/com.qrecall.scheduler.plist (OS X 10.5 only). The scheduler is configured to run in the "background" so it should get launched whenever you log in or start up, and should then run forever.

But that's not what's happening. Something is killing your scheduler when you log out:

My tests today suggest that the Scheduler is being killed when I shutdown. When I log out and sleep my MacBook the Scheduler is there when I log in. By the way I'm testing Scheduler's presence by running Activity Monitor immediately after logging back in.

My only suggestion is that you track down what might be killing the scheduler or change the option to run the scheduler only while you're logged in. This would install the scheduler as a user agent, just like the QRecallMonitor, which seems to be working.

I tried this (deleting the preference to run when not logged) and all went well. Activity Monitor confirmed that the Scheduler was running and QRecall ran a back-up as soon as the external drive mounted. QRecall then surprised me by asking if I wanted it to install the Scheduler (which was running at the time). I allowed it to do this. Doing so caused it to set the preference to run when I'm not logged in. I left it set and logged out followed by sleep. Logging back in I found Scheduler still active. I tried to see if closing the screen lid had any effect - it didn't. Then I shutdown. On restarting I found Scheduler had been killed.

I've sent you a new diagnostic report and can send you some screenshots. Perhaps the answer is to change the option to run the scheduler only while I'm logged in and then not to install the Scheduler if/when QRecall asks that it should. Ideas?
James Bucanek wrote:Open your QRecall preferences, go to the Authorization tab, change the option that says "Start and run actions while logged out", wait a few seconds, and change it again. This will cause QRecall to uninstall and reinstall the scheduler (twice). I suspect that you want this option off as Mac OS X doesn't mount volumes while you're logged out, so trying to run actions while logged out doesn't do any good.

Have done as you request. The preferences were for QRecall to run when logged out so I turn this off and on again. By the way QRecall tried to run a back-up as soon as it as launched even though the external drive was not mounted. Surely it shouldn't do this? On my iMac I have QRecall set to wake from sleep, mount the external drive and run - works like a charm. Have been doing this for several versions as I found that Cocktail allowed me to tell the OS to mount external disks when I'm not logged in.
Now, log out and back in (or restart) and send me another diagnostic report. I'll be able to tell if the scheduler gets restarted when you log back in.

Report on its way, delayed by major electric storm that took out my modem/router (tho' protected by UPS unit). QRecall didn't try another back-up though I did mount the external drive, this is as it should be for it is meant to wait 12 hours between back-ups. Activity Monitor on my iMac shows QRecallMonitor and QRecallScheduler running while the MacBook only shows QRecallMonitor - no QRecallScheduler.

Charles
Report on its way.
On my MacBook Pro (10.5.7) I have QRecall (1.1.2) set up to run a back-up sequence as soon as the external firewire drive mounts. This is however not happening but does as soon as I launch QRecall. According to Activity Monitor both QRecallMonitor and QRecallScheduler are running. Have I found a buglet? If not, what should I do to make sure the Action sequence does run?
James Bucanek wrote:The warning indicator appears in the QRecall Activity window when an action fails to finish properly. If the activity monitor process isn't running, most likely because you're logged out at the time, then there's nothing to catch and display the warning. Also, if you use spaces the warning may be appearing in another space.

I understand now. I don't use Spaces but I do run my back-ups when I'm logged out.
I'll add a wish list item to be notified of problems that occur while you are logged out.

Sounds good. Perhaps it could email the affected user as soon as someone logs in to the machine?
I seem to recall that QRecall should alert the user to errors through a QRecall Activity Monitor message which is displayed until dismissed by the user. This does not seem to be so on my machine and I wonder if it's a problem with my installation or something more general.

I have QRecall set up to back-up at night when I'm logged out. Before a recent vacation, I 'suspended' all its operations. On return I 'reactivated' them all. As QRecall did not display any error messages, I assumed that all was well. Yesaterday I launched it to check. I was disturbed to find that it had not made any back-ups since its 'reactivation' - a period of nearly two weeks. The reason was that the archive indexing was wrong and the archive did not therefore open. QRecall repaired the index and all is now well again.

Is there a way to ensure that QRecall advises errors automatically? If not, might I add it to the wish list?

-- Charles
Please forgive my ignorance. What are 'extended attributes' and why should I try to 'nudge' files captured pre-1.1.0(25)? Or rather what am I missing if I don't 'nudge' them?

-- Charles
 
Forum Index » Profile for Charles Watts-Jones » Messages posted by Charles Watts-Jones
Go to:   
Powered by JForum 2.1.8 © JForum Team