QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: Ralph Strauch
Forum Index » Profile for Ralph Strauch » Messages posted by Ralph Strauch
Author Message
The Energy saver control pane contains an option to "Wake up for Ethernet administrator access." Would it be possible for qrecall to generate such a request, so that other computers on a network could wake up the one with the backup drive attached to do backups?

Related question: Could qrecall have an action to wake up for a scheduled backup rather than scheduling the wakup separately in another place?

Rallph
Glad to hear it. Thanks. I really appreciate your responsiveness and the level of support you give this app.

Ralph
I had another network interruption this week, again resulting in a corrupted archive. This one happened when my wife put her iMac to sleep while my MacBook Pro was backing up over airport to an external drive mounted on the iMac.

I grant that this can be seen as a case of operator error that shouldn't happen, but inetwork interruptions of one kind or another are not so rare events that they should be discounted. Is it possible to make Qrecall more forgiving of network failures so they don't result in corrupted archives?

Ralph
James Bucanek wrote:
I'm profoundly sorry to be the bearer of bad news (again), but using QRecall with Apple's iDisk service does not work well.

There was a long thread on this some time back (Online Storage). To avoid the pain of reading the whole thing, I'll summarize:


Thanks for the info. I'm sorry I didn't come across the other thread before I tried the remote backup. I guess I'll just keep using Apple's Backup for my idisk backup of critical files.

I have one remaining problem I wonder if you can offer any advice about. I've deleted the empty qrecall archive from the idisk, but it still shows only 2.4gb of free space rather than the 5.8gb I had before the backup. Apparently it allocated 3.4gb of space for the qrecall archive even though it didn't use it, still keeps that space as used, even though it doesn't show up as allocated to any particular folder.. Do you know anything I can do to get that space back?

Thanks,
Ralph
Here's log for my previous posting. I attached it to that posting and it showed up as attached, but the post itself showed up with <br>'s in place of the returns, I guess because I wrote it in a text processor and pasted it in. I then edited the post here to put in unix returns and in the process, lost the attachment. So here it is again
I continue to have problems with interrupted backups and corrupted archives, this time with a remote backup of my documents folder to my wife's iDisk. The backup appearer to proceed normally but hung up at the end, and the archive somehow disappeared. The sequence of events is outlined below, and the log file covering those events is attached. Key events described below are marked in the log file with three asterisks (***).

At 2008-03-21 17:53 I mounted the iDisk (/Volumes/mstrauch) with 5.8gb of free space. At 18:08 I created "rdocs archive.quanta," and at 18:09 began to capture my 3.4gb documents folder to that archive. The capture appeared to be going well, with the blue progress bar filling in as the capture progressed. I went away from the computer and came back after a couple of hours to find the blue bar had progressed to the end and the activity monitor said it was capturing a file that was the 2nd to last item in the documents folder contents list. It stayed like that until 22:09 when I decided that it was completely hung and tried to cancel the capture. Qrecall acknowledged my cancel requests but remained hung with the same display in the activity monitor. I attempted to force quit Qrecall, but it failed to quit and remained in the dock. I shut the lid of my laptop and went to bed.

This morning when I got up and opened the computer (07:44), Qrecall shut itself down. My idisk showed a empty archive (0kb). I tried to open the archive at 8:01 and was told it needed to be reindexed. When I reindexed it, it was empty, and now occupied 16kb, which I presume is from the index. There are no log entries between start of the capture last night at 18:09 and my attempt to cancel the hang-up at 22:09, to indicate what happened during that period. I suppose the hangup could have been caused by a network failure or the idisk unmounting itself, but there's no indication of that in the log, and the iDisk was mounted at 22:09. The backup appeared to be working properly earlier on and my available disk space is now only 2.4gb, which is about what it should be after the backup. But I can't tell what happened to the archive or the disk space. I thought about deleting the archive to see if that would give me back my disk space, but decided to see first if that file would be useful to you.
I'm continuing to have problems with QRecall hanging up and failing to exit properly, leaving me with a bad archive that needs repair.

I began a backup at 2008-03-12 23:54:54.687 and left it. I came back about an hour later to find that it had hung, with the activity monitor showing 99 items processed and the log showing a failure to make a filter item for an excluded folder that I had deleted from the source drive. I deleted that folder from the action exclusion list and tried to restart the backup at 2008-03-13 01:28:10. QRecall was hung so I had to force quit it. I think it wouldn't force quit properly and I had to reboot the computer to get it to run again, but I'm a bit hazy on those details right now.

I restarted the backup at 2008-03-13 01:43:51.499 and it failed due to an invalid header length. I started a repair at 2008-03-13 01:48:19.045 and went to bed. When I got up the next morning I found that the repair had failed almost immediately at 2008-03-13 01:48:20.562 due to "Found 24 bytes of invalid data at file position 2424." It also looks "from the log as if the backup disk was dismounted shortly thereafter. It was not mounted when I checked it in the morning.

To help you interpret the log, MBPHD is the source drive on my MacBook Pro being backed up. "spare" is the backup volume, and the backup disk also contains volumes "leopard" and "Mac OS X Install DVD." The unmounted backup disk is the same condition I described on March 8. I assumed then that it was a problem with my drive, but now seeing it occur again immediately following a Qrecall failure I wonder if that is the case. Can you tell from the logs? Are some of these problems with my system, or is it all due to QRecall?

In any case, I think QRecall needs a softer failure mode, allow the program to exit properly without requiring a force quit and sometimes even a reboot.

I'm attaching a file containing the log starting at the point that I mounted the backup drive. Entries for the events described above have been marked with astericks *** to make them easier to locate. The log file also includes a lot of entries for time periods when QRecall isn't active. Is this normal?

Ralph
James Bucanek wrote:

What's odd is the error code. Error code -5000 is normally an access error to a file on a network volume, not a USB device. But then again, you said that you're using some special USB drivers? That might be a factor.


I think I was using a Firewire connection for that backup, because of my earlier problems with USB. I'm not using any special USB drivers, though. My USB port had gone dead during an earlier backup but then resuscitated itself after a system restart, so I thought that might have been a problem with the system drivers.

Ralph
James,

Thanks for the prompt reply and all the information. I merged the two layers, as you suggested, and the archive looks fine now.

Here are the logs around the time that QRecall was unable to process the lproj file and hung up, in case the information is of value to you. The failure occurred at 2008-03-06 01:08:22.

2008-03-05 22:00:00.362 -0800 Minutia Waiting for permission to open archive [2.733106.569.8]
2008-03-05 22:00:06.079 -0800 Minutia Acquired permission to open archive [2.733106.569.9]
2008-03-05 22:00:06.081 -0800 Capture MBPHD [2.733106.569.10.1]
2008-03-05 22:00:06.093 -0800 Details MBPHD [2.733106.569.10.1.1]
2008-03-06 01:08:22.284 -0800 #debug# Reopened log file [2.733106.569.12]
2008-03-06 01:08:22.152 -0800 Failure Could not capture Localizable.strings [2.733106.569.11]
2008-03-06 01:08:22.391 -0800 Details File: MBPHD:Libraryrinters:EPSON:InkjetPrinterrintingModuleXG900_Core.plugin:Contents:Resources:Japanese.lproj:Localizable.strings [2.733106.569.11.1]
2008-03-06 01:08:22.404 -0800 Caution Problems processing items [2.733106.569.13]
2008-03-06 01:08:22.405 -0800 Details archive I/O error [2.733106.569.13.1.1]
2008-03-06 01:08:22.405 -0800 Details Data exception [2.733106.569.13.1.1.1]
2008-03-06 01:08:22.405 -0800 Subrosa .Explain: datawrio [2.733106.569.13.1.1.2]
2008-03-06 01:08:22.406 -0800 Details Cause: <IO> cannot read envelope data { PkgNumber=2128924, Class=FileSource@0x133a70(/Volumes/spare/bu-archive.quanta/repository.data), API=FSReadFork, Pos=45118276456, OSErr=-5000, Length=8828, File=/Volumes/spare/bu-archive.quanta/repository.data } [2.733106.569.13.1.1.3]
2008-03-06 01:08:22.406 -0800 Details Path: MBPHD:Libraryrinters:EPSON:InkjetPrinterrintingModuleXG900_Core.plugin:Contents:Resources:Japanese.lproj [2.733106.569.13.1.2]
2008-03-06 01:08:22.406 -0800 Failure Could not process folder Japanese.lproj [2.733106.569.13.1]
2008-03-06 08:10:34.907 -0800 #debug# Reopened log file [1.733106.245.25]
2008-03-06 08:10:34.906 -0800 Minutia Saved Capture MBPHD to bu-archive.quanta action [1.733106.245.24]
2008-03-06 08:10:34.929 -0800 Details file: /Users/ralph/Library/Preferences/QRecall/Actions/bu-archive.quanta-capture (2).qraction [1.733106.245.24.1]


Ralph
I've had a problem this week with interrupted backups and corrupted archives. Part of the problem was with my computer and qrecall may have been fine, but I'd like the describe what happened and see what you think.

Wednesday evening I initiated a backup to an external WD hard drive. Qrecall ran for a couple of hours and then hung. I unsuccessfully attempted to rerun it and eventually realized that my USB port had failed and the external HD was no longer mounted, so that was the cause of the backup failure. (The USB failure must have been a driver failure, because after a restart the port is working again.)

The archive was corrupted (header length invalid) and would not reindex. I didn't have enough free space to repair it, so I trashed it, started a new backup, and went to bed. In the morning I found that it had hung at 1am with a "Cannot capture localizable strings" error referring to a Japanese lprog file in a printer driver. I excluded that file from capture (though it had been previously captured without error) and tried again.

Again, I found that my archive was corrupted with a "header length invalid" error. This time I repaired the archive and recaptured, and everything seemed to work -- except for the layer information in my current archive. My current archive is 87gb, and shows that it contains two layers. Layer 1, which I think is the repaired version of my 44gb corrupted capture, shows and unknown time of capture and 0gb in size, while layer 2 shows the time of my latest capture and 52gb size, the same size shown for the capture in the log. I tried reindexing the archive to see if this would correct the layer 1 info, and it doesn't.

So I think I've probably got a good archive now, and the layer info just got lost in the repair process. I'm a bit concerned, though, because the 44gb first capture and 52gb second capture together only give me an 87gb archive. Am I missing something here?

Ralph
I haven't installed Leopard and actually looked at Time Machine yet. Based on what I've read it looks to me like both provide the same basic functionality, in terms of the versions of files saved, etc. The differences I see are in the user interface and the amount of space used.

Time Machine appears to have a "prettier" and more transparent UI. The ability to go back and see old versions with QuickLook looks nice. I think Time Machine backs up changed files rather than changed sectors, so it's archive will grow much more quickly than QRecall's. QRecall, OTOH, has a "geekier" UI requiring a bit more computer savy, but will use much less space for its archive or be able to save more layers in the same space.

Is a good summary of the differences, or is there anything important that I'm missing here?

The space difference is a biggie, and this week when people are installing Leopard and exploring Time Machine would be a good time to promote that heavily. In the MacIntouch reader report on Leopard, http://www.macintouch.com/readerreports/leopard/ a number of people are expressing concern about Time Machine's archive growing rapidly because of small changes to large files. They'd likely be good candidates for QRecall right now. I'll post something about it if you'd like me to, but it might be better if you did it yourself.

Ralph Strauch

James Bucanek wrote:
I forgot to mention, you should really use two identity keys if you are capturing two different systems to the same archive.


Why are two different keys needed? I want to back up my MacBook Pro and my wife's iMac to the same archive, and in my small test archive there doesn't seem to be any problem doing both using the same key. Each layer gets identified with the proper volume, and only the selected volume is active.

Related question? should it be possible to have a firewire drive mounted on both computers at the same time? It seems so, because the drive could be mounted on both computers using ethernet, and the firewire connection can also provide an IP network. When I try, though, the drive won't mount on the second computer I attach it to, and then it won't mount at all until I power it down and back up again.

Ralph Strauch
 
Forum Index » Profile for Ralph Strauch » Messages posted by Ralph Strauch
Go to:   
Powered by JForum 2.1.8 © JForum Team