QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: James Bucanek
Forum Index » Profile for James Bucanek » Messages posted by James Bucanek
Author Message
Greetings,

I assume you're talking about the Run menu in the QRecall Monitor's menu bar icon and/or dock icon.

That list is built from the actions you have defined. If you're seeing actions that are no longer relevant, simply delete them.

Open the Actions window (Window > Actions) and do whatever housekeeping you deem appropriate.
Ming-Li Wang wrote:One minor suggestion, if I may: please consider adding a set of "Save/Cancel" buttons to the action settings dialog. Having to close the window before being offered an opportunity to save the settings feel odd.


An action document window, which you get if you open the action from the Actions window or by choosing "Edit in Separate Window", is a standard macOS document window. Changes aren't saved until you choose File > Save, or try to close the window without first saving it.

QRecall's UI became a little more complicated (read "inconsistent") when action documents were added to the sidebar in the archive window. Since the "Save" command doesn't apply to an archive document, and the sidebar can show multiple action documents at once, the "hack" was to add individual "Save" and "Revert" buttons to the sidebar interface—equivalent to the standard File > Save and File > Revert commands.

So while I appreciate the confusion, I'm reluctant to add yet another layer of non-standard window behavior when the action is being edited in its own window.
Sorry to hear you're having problems with the beta.

The first thing to try is to open the action and remove, and then re-add, all of the items to capture. Then save the action and see if that helps.

The location of the items to capture are stored as bookmarks, and it's possible those they were out-of-date. Removing and re-adding them will create new bookmarks.

Also, send a diagnostic report. (Open the QRecall application and choose Help > Send Report). This will upload your recent log records so we can examine them. These records contain a lot of low-level details about the scheduler and change events.
If the system won't bless the volume, it means the operating system is cryptographically signed and you'll have to reinstall the OS on top of your restored volume to make it bootable again.

"Security is the opposite of convenience." -- unknown
That message means that QRecall couldn't "bless" the startup volume for you. It just means you'll have to do it manually using the Startup Disk system preferences pane.
Mike,

The "Lifeboat" volume is just a temporary volume used to as a springboard for recovering your system. You use recovery mode to create the temporary volume and install a bootable OS. This OS is not the OS you will eventually install or recover, and doesn't need to be the same version.

The volume you eventually recover will be some other volume, either your original startup volume, or a new volume that you create and restore to.

If you don't see an option to reformat the entire drive, repartition, or add a new volume, then you need to switch Disk Utility's view mode to "Show All Devices." In the simpler "Show Only Volumes" mode it only lists logical volumes that have already been created. The "Show All Devices" mode shows the logical tree of hardware, partitions, containers, and logical volumes.

Mojave is the last macOS you can restore a bootable startup volume using QRecall. So if you follow my previous instructions (create a new APFS volume and restore your volume to that), the results should be bootable. Also...

Steps for downgrading macOS:

  • If you're also restoring from QRecall, it's cleaner if recall your volume from QRecall before re-installing the (old) OS over it.

  • Download an earlier macOS installer using the (not-so-)secret App Store links.

  • Create a small HFS+ volume on an internal/external drive, or use a largish USB thumb drive (on computers that can boot from a USB drive).

  • Create a bootable installer using the createinstallmedia tool that's imbedded in the macOS installer app.

  • Reboot from the volume the tool just initialized and install your old OS somewhere (on a new volume, or into the volume you restored with QRecall).


  • Note: I've noticed that using a USB thumb drive has been problematic with some recent Macs. I have a Mac Pro 2019 that I cannot boot from a Big Sur installer volume created by createinstallmedia, even though this Mac shipped with Catalina. (It starts to boot, and then just crashes.) But if I add a small volume partition to a spare internal SSD, it boots from that just fine.
    Mike,

    At that point the computer was able to boot off its system volume. But it was running Monterey. I naively expected it to be running Mojave.


    Mojave is pre-Catalina, so it exists as a single volume. Catalina and on, the startup volume is a volume pair: an immutable system volume and a mutable data volume.

    During the Monterey install, your single volume was split into a system volume and a data volume. When you then restored your Mojave volume to it, you only ovewrote the data volume. The core operating system (Monterey) is still on the immutable system volume, so that's what'a going to boot. And yes, you've created a kind of Frankenstein OS that will probably exhibit some bizarre behavior.

    To jump back to Mojave, you need to completely erase the Monterey System/Data volume pair, create a new (single) APFS volume, and use QRecall to restore that. That should get you back to running Mojave, from which you can then proceed forward.

    Mike,

    Sorry to hear about your trouble upgrading your OS.

    There are a number of paths to follow. One is the command line, but that's pretty technical.

    Here's my suggestions:

    First, start by simply trying to preform the upgrade again. This would be the simplest solution, if it works. Even if your startup drive isn't bootable, you can always reinstall the most recent macOS that your hardware supports using recovery mode. It's entirely possible that something went sideways during the upgrade (and jumping three major version in a single go is fertile ground for complications).

    Hard reboot your machine and start it up in recovery mode. Then just try installing Monterey again. If that works, you're done. (As much as I love it when people use QRecall to solve their problem, NOT having to perform a full-system restore is usually a simpler solution.)

    However, if you now believe that your startup volume has been trashed and is unrecoverable, you can restore from QRecall and reinstall macOS. The easiest way to do this is from a second bootable volume. Since you didn't create one ahead of time, create one now—and again, recovery mode and APFS are your friends:

  • Start up in recovery mode

  • Use the Disk Utilities to erase/reformat your startup drive

  • Create a new APFS volume on the drive named Lifeboat (or something)

  • While still in recovery mode, install macOS on the new Lifeboat volume (user name, passwords, settings don't matter; just keep it simple)

  • Now that Lifeboat is installed and booted, download QRecall and install it

  • Launch Disk Utility and create a second APFS volume (APFS containers can hold multiple APFS volumes that share the same space); this will be your new startup volume

  • Launch QRecall; open your latest archive and select the volume to restore, hold down the option key and choose Restore Volume To...

  • Select the volume you just created in Disk Utility and start the restore; this will take awhile

  • When you're done, either download the Monterey installer again from the App Store, or use recovery mode again, and install Monterey on top of the restored volume

  • If successful, you can use Disk Utility to delete the Lifeboat volume


  • Now if all of that doesn't work, then there's a serious problem installing Monterey on your startup volume. Alternative solutions would be to upgrade to an intermediate OS first (rather than trying to jump directly to Monterey). Another approach would be to install a blank version of Monterey on a new volume, then use the migration assistant to import your old startup volume, rather than trying to install the OS directly on top of an existing installation. The latter approach assumes you have enough disk space, and there are a few tricks to make that possible too, so post again if you're still stuck.


    Johannes,

    We are aware of the problem of actions windows not displaying, but have yet to reproduce it here. We've tried QRecall 3.0.x on both Intel and M1 Macs, on macOS 12, 11, and 10.15, we've even tried opening the actual action documents from users having this problem and still can't replicate it.

    So now we're asking for beta tester help.

    If you're having this problem, please try the following:

  • Open the Console app.

  • Select your device (computer name)—it should be the default—on the left.

  • Click the Start Streaming button; you may have to enter your admin password the first time.

  • Enter "QRecall" into the search field, upper right.

  • Open QRecall.

  • Try to open an action window, from the actions window, or create a new action.

  • If the window contents are blank, continue...

  • Switch back to the Console app.

  • Click the Pause button in the toolbar.

  • Select everything in the window and copy it to the clipboard.

  • Create an email to support@qrecall.com and paste in the results.

  • Follow up by sending a diagnostic report in QRecall (Help > Send Report).


  • This will help us look for anything unusual that might be getting logged by the system UI that's preventing the action windows from displaying.

    Thanks for reporting this, and thanks for helping make QRecall better. Beta testers are the unsung heroes of software engineering!
    The manual for QRecall is bundled in the application. Download it, install it, and chose Help > QRecall Help.

    There's also a fairly recent copy of the manual on-line.

    As long as you can mount the storage for your Micro PC as a volume on the Mac, QRecall should work.

    While QRecall is focused on capturing and restoring macOS native filesystems, the archive can be stored on any volume that can be mounted on macOS, which includes networked servers, NAS devices, thumb drives and more. Not every filesystem is supported (because some are flawed), but that's the goal.

    In the past, it was possible (although not recommended) to capture and restore your Spotlight database.

    The latest versions of macOS, however, makes a lot of the spotlight data inaccessible, even to processes running as root. So if you did capture those files in the past, I'm not at all surprised you can't restore them now.
    Mike M wrote:I found the section of the log at the point the restored finished. Maybe you can explain this.

    That's simply the summary message that one or more issues were encountered. You'd have to search back through the log to find the specifics of the/each issue.

    If you like, compress your log file(s), email them to support@qrecall.com, and we'll take a look at them for you. (We have a number of automated tools for combing through log files looking for problems.)
    Mike M wrote:But I'm thinking that if the recall was incomplete, then I'm missing data

    That is entirely possible.

    Mike M wrote:What I'd really like to do is verify it against the archive at the time of recall.

    A verify action only validates the internal consistency of the archive. It doesn't compare what's in the archive to what's on disk. There's currently no function that will tell you the difference between what's on a volume and what's in the archive, although that is a requested feature and is still on the wish list.

    (Well, that's not exactly true; in the archive browser you can choose Edit > Select Existing Items, which will effectively compare the files in a browser view against what's on the volume, but it only works for the currently displayed folder.)
    Then that's very odd. Then the message is probably in there somewhere. You might increase the detail level of the log window. Or you can just search the log files manually (they're just plain text files). less and grep are your friends.

    The recall issue you saw was most likely something to do with the recall process itself; a permission error, or out of disk space, or something like that. A data corruption in the archive (which is what a verify would reveal), would have stopped and immediately terminated the recall command with a fatal error.
     
    Forum Index » Profile for James Bucanek » Messages posted by James Bucanek
    Go to:   
    Powered by JForum 2.1.8 © JForum Team