QRecallDownloadIdentity KeysForumsSupport
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Groups] Back to home page 
Messages posted by: David Ramsey
Forum Index » Profile for David Ramsey » Messages posted by David Ramsey
Author Message
Actually, it's starting to look as if El Capitan will mark the end of my many years of Hackintoshing. I've never had to spend this much time trying to get a stable and reliable-- hell, bootable-- system up before. The tools may improve to the point where it's workable, but for now, I'm giving up: I've sent all afternoon trying to get El Capitan to boot reliably, and at this point just don't have the energy any more.

In the meantime, QRecall remains dead stable and reliable under Yosemite, but if I have trouble on whatever El Capitan system I eventually wind up with, I'll let you know.
I'm experimenting with El Capitan on a new volume. I downloaded a fresh copy of QRecall from the site, but it's unusable: if I click the "Open Archive" from the Quick Start window-- or select "Open Archive" from the [File] menu, nothing happens...the file selection dialog never appears.

If I invoke QRecall by opening the archive file directly, QRecall comes up and immediately crashes.

Any solutions for this? I'm running El Capitan 10.11.1, admittedly on my Hackintosh, but QRecall has been running fine on this system for years.
My brother switched to QRecall on my recommendation some time ago after years of problems with Time Machine (can there be such a thing as too many hard links? Empirical evidence would suggest the answer is "Yes. Yes there can." But I digress.)

He and his wife share the computer and each has their own account. For some reason, logging into his wife's account no longer works-- he gets a gray screen and spinning beachball of death. The local Apple store had it for two days and pronounced it fixed, but upon returning home he found the same problem.

My off-the-cuff suggestion was that he create a new user and use QRecall to restore all the files backed up in his wife's original account to the new account-- you know, her desktop, Documents folder, Pictures folder, etc. But then it occurred to me that there would likely be permissions issues with this.

So my question is: What is the best way to accomplish what I want? He's understandable nervous about simply restoring over the old account, although as I understand it this should be a pretty safe bet if QRecall hasn't flagged any problems with the backup.
I wound up reinstalling the OS with a test user account, then using QRecall to restore my user account and selected apps. Fortunately it wasn't necessary to call Microsoft or Adobe.
Hm. I misspoke: I had Show Invisible Items turned on, now Show Deleted Items.

(It's been a long night...)

I am debating whether or not to try it again-- it would be nice if it worked, since I wouldn't have to beg indulgences from Adobe and Microsoft...
James Bucanek wrote:
3. Any ideas on why a whole-volume restore didn't work?

I don't know. In theory, you shouldn't have any problem restoring a bootable OS X volume. Here's some things to look out for:

  • The "Show Deleted Items" view option was not turned on.


  • Hm. It was turned on. Why should that make a difference?

  • After formatting the new drive, and before restoring, make sure the "Ignore ownership and permission" option was not checked.


  • Checked where?

  • I assume that both the capture and restore were authorized to use administrative privileges.


  • Yes.

  • I assume you restored the volume by holding down the option key and choosing Archive > Restore Volume To... (or by dragging the archive volume icon, dropping it into the restore volume, and choosing the "Replace Volume" option when the dialog popped up).


  • No; I backed out to the first level of the archive, right-clicked on the volume, and selected "Restore". Is that valid?

  • Did you try blessing the volume after restoring it?



  • Shades of System 9! Not even sure how I'd do this on OS X...but no. I didn't have any way of mounting the volume.

    I should emphasize that I was restoring to the volume I booted from, which I assume is OK.
    I know, I know: it's not a real Mac. But still: the boot volume should be separate from all the under-the-hood tricks that get it working.

    So why after a volume restore, does an attempt to boot the system result in the "No mach_kernel" message?

    Procedure: re-create the volume with a fresh install of OS X. Install QRecall. Run it and restore the existing volume from the backup.

    Since that didn't work, I'm currently restoring my user folder and will work on reinstalling apps manually. The restore, from a 2TB hard drive to a 512GB SSD, seems to be taking a very long time (4 hours, 51 minutes and counting). After the initial progress bar finished (about 40 minutes ago), it changed to a barber pole and it still going. Now, it might be that's just a result of the restore process having to re-assemble files from pieces. But as long as I'm here, a couple of questions:

    1. My backup currently has 57 layers. Is that an unusually high number? Should I merge more often?
    2. What's going on when the barber pole is animating?
    3. Any ideas on why a whole-volume restore didn't work?

    Thanks...
    As it turns out, the problem was that Intel Virtualization Technology had somehow become turned off in the BIOS. Once I turned that back on, everything was OK.
    I have a Parallels VM of Windows 7 which I use occasionally to do some Windows-specific stuff.

    Today when I launched the machine, it stuck in an endless loop of "Windows is loading files..." followed by a restart of the VM, followed by "Windows is loading files..."

    No problem. I'll just restore an earlier version.

    I've tried this several times, going back more than a month with the same results on restore. I'm pretty sure I'm doing it the right way, but wanted to check:

    1. Drag bottom shade up to date you want to restore from
    2. Select item to restore
    3. Click "Restore"

    In this image, I assume I'm restoring "Windows 7.pvm" from January 12. Right?
    Sure. Who could forget const_cast, reinterpret_cast, static_cast, and dynamic_cast (I think. From memory.)?

    Java was always a better, more modern language, but despite efforts by some very smart people, stand-alone Java apps just never worked that well.

    OK, enough off-topic...
    Yep, that did it (changing the actions). Thanks!

    Stinking scripting languages. Really only fit for kids.

    (OK, yeah, resetting the clock was independent of PHP. Still, I never thought I'd see the day when I missed C++...)
    I was working on some PHP code a few days ago, and adjusted my computer's calendar to May 1, 2013, to test some date code.

    My code worked fine, but QRecall immediately started to perform a backup. Which is entirely reasonable.

    I aborted the backup and set the clock back to the correct date and time.

    That was Tuesday, and I just noticed that QRecall hasn't run a backup since then. If I open the archive the last backup is shown as Monday, January 14th. The next backup is scheduled for Wednesday, May 15th...

    How can I force QRecall to get "back on schedule"?
    Done. Man, I'd like to know the database architecture you have underlying this. Something tells me it's not an SQL-type relational with BLOBs...
    And...that was it. I suspect the new archive was created when I added the identity key.



    I suppose I can simply delete the lower archive dated 5/14...
    In that case, I think I am Doing Something Wrong. For example, the Documents folder contains my Parallels virtual machines. I see QRecall thrashing through my Win 7 VM almost every day (because I use it frequently), but no backup of it is shown past May 19.

    A better example might be my Desktop folder. It changes daily, and yet it doesn't show any changes past that date either (and yes, I am running a Hackintosh. Now that I'm retired I can't justify new Mac Pros any more. I don't think this should make a difference, though...)

     
    Forum Index » Profile for David Ramsey » Messages posted by David Ramsey
    Go to:   
    Powered by JForum 2.1.8 © JForum Team